0

I am trying to install ubuntu 14.4 version. I am using a USB wireless Logitech keyboard. the kb works fine till the install screen. The moment i start the installation and the languague screen pops up, the kb stops working.

i have gone through multiple forms, but not able to get a answer to make it work. I am using a Asrock C2750D4I motherboard and i dont have a option in the BIOS to enable / disable support for legacy KB.

Can someone help in resolving the problem.

2
  • Please be specific, what is the model name of the Logitech keyboard? Some like the MX5000 have improperly configured udev rules in Ubuntu for years showing the same behavior I observed on my DiNovo Edge and that you apparently still have.
    – LiveWireBT
    Dec 6, 2015 at 16:15
  • I am using a logitech K350 Wireless keyboard Dec 7, 2015 at 0:06

1 Answer 1

0

Do you have another (wired USB) keyboard to hand? If so, I would use that for the installation process. Once Ubuntu is installed and working happily with the wired keyboard (i.e. fully up to date including kernel updates, which might be important), if your wireless keyboard still doesn't work you can try looking for additional drivers or scripts (such as this one).

4
  • if your wireless keyboard still doesn't work you can try looking for additional drivers or scripts (such as this one) - I am getting stuck at the first screen of ubuntu installation itself, not sure how i can run these scripts. it is a fresh install on a newly built system. Dec 6, 2015 at 16:40
  • no i dont have a wired KB on hand. Also the motherboard is a server grade mother board C2750D4I(Asrock), it does not have a seperated port for keyboard. Dec 7, 2015 at 0:06
  • I would suggest borrowing a wired keyboard from someone then. If it has a USB socket, then just borrow a wired USB keyboard and plug that in. That should get you through the installation, and then we can sort out getting your wireless keyboard working (if it doesn't already by that stage).
    – Gsxr1k
    Dec 7, 2015 at 10:08
  • okay thanks, let me give it a shot. have thought will try couple of things. 1. have ordered for a USB header , will try to plug in the wireless usb to the USB header and Motherboard directly and see if that works. 2. will borrow USB keyboard and check if that works Dec 7, 2015 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.