-1

Last week while I was installing the texlive-full in the Ubuntu system in VMWare I found that it took too much time, and then I went back home left it installing. But when I came back, something weird appeared:
1. Many Vim plugins yelled at me.
2. After rebooting, I got stuck with a totally black screen.
3. My Genome was gone. I can only interact with the OS via command line after hitting Ctrl+Alt+F1.
4. Since I got to know that I need extend the disk space for the Virtual machine, I attempted to get it done by following this awesome tutorial, but got stuck again when trying this command pvcreate /dev/sda3. The system told me that it had not been installed. But when I run sudo apt-get install lvm2, it reminded me that I should run sudo apt-get -f install with no parameters instead first.
5. But I saw that the failed texlive-full was being installing, and again it failed because of the limited space issue.
6. Then I deleted about 1.5G of files. I checked it by running df -h after sudo apt-get clean. But when I run the command I run in the 4th step, the error saying E: Write error - Write (28: No space left on device) E: The package lists or status file could not be parsed or opened. reoccured.

Then my question is that what I can do to undo the interrupted installation of texlive-full? It seems that it has not been automatically undoed after the failure. I don't want, and it seems that I need not, to delete more files for more space.

  • 1
    I would recommend booting from a live cd and extend your disk space first then update everything. – DnrDevil Dec 6 '15 at 13:29
  • 1
    post (pastebin) the exact command you ran and the exact error message. I am guessing /boot or some specific partition is full – Panther Dec 6 '15 at 13:32
  • @bodhi.zazenSorry I cannot reproduce the prompts which guide me to run apt-get -f install. All errors shown are the same as that one in the 6th step. – Lerner Zhang Dec 6 '15 at 13:39
  • @DnrDevil I don't get you, could you please answer the question in detail? Or redirect me to some tutorials? – Lerner Zhang Dec 6 '15 at 13:42
0

I have tackled the problem by four steps: 0) delete some files and complte the installation and then remove the software; 1) Set the VMware to extend the storage; 2) create a new filesystem and mount it to the root one; 3) install the latex by setting the installing directory.

#   TEXLIVE_INSTALL_PREFIX         /usr/local/texlive   => $tex_prefix

According the the above line in the install_tl file and the explanation in the documentation I get to know that I should change the value of the variable tex_prefix only.

Reference
http://www.tug.org/texlive/acquire-netinstall.html

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.