0

Follow up on: Wireless card Realtek RTL8723AE-BT is not recognized

I have the exact same problem as described in the person's previous question. To elaborate on my current situation; I right now use a Netgear USB wireless dongle to connect to the wireless.

Here's some information: Contents of the wireless script from ubuntuforums:

########## wireless info START ##########

Report from: 08 Dec 2015 20:44 CET +0100

Booted last: 08 Dec 2015 20:03 CET +0100

Script from: 27 Sep 2015 00:34 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:    14.04
Codename:   trusty

##### kernel ############################

Linux 3.16.0-45-generic #60~14.04.1-Ubuntu SMP Fri Jul 24 21:16:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, intermap=off, quiet, splash, vt.handoff=7

##### desktop ###########################

Xubuntu

##### lspci #############################

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter [10ec:8723]
    Subsystem: AzureWave Device [1a3b:2114]
    Kernel driver in use: rtl8723ae

02:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8161 Gigabit Ethernet [1969:1091] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:10f5]
    Kernel driver in use: alx

##### lsusb #############################

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 13d3:3394 IMC Networks 
Bus 003 Device 002: ID 04f3:0155 Elan Microelectronics Corp. 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

1: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
6: phy5: Wireless LAN
    Soft blocked: no
    Hard blocked: no

##### lsmod #############################

rtl8723ae             166569  0 
msi_wmi                13354  0 
sparse_keymap          13948  1 msi_wmi
btcoexist             183378  1 rtl8723ae
rtl_pci                39740  1 rtl8723ae
rtlwifi               101788  3 btcoexist,rtl_pci,rtl8723ae
mac80211              652777  2 rtl_pci,rtlwifi
cfg80211              498458  3 mac80211,rtlwifi,8812au
wmi                    19193  1 msi_wmi

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

eth0      Link encap:Ethernet  HWaddr <MAC 'eth0' [IF]>  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:36 

wlan0     Link encap:Ethernet  HWaddr <MAC 'wlan0' [IF]>  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

##### iwconfig ##########################

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off


##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

##### resolv.conf #######################

nameserver 127.0.1.1

##### network managers ##################

Installed:

    NetworkManager
    Wicd

Running:

root       960     1  0 20:03 ?        00:00:02 NetworkManager

##### NetworkManager info ###############

NetworkManager Tool

State: disconnected

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8723ae
  State:             disconnected
  Default:           no
  HW Address:        <MAC 'wlan0' [IF]>

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            alx
  State:             unavailable
  Default:           no
  HW Address:        <MAC 'eth0' [IF]>

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########


##### iw reg get ########################

Region: Europe/Amsterdam (based on set time zone)

country NL:
    (2402 - 2482 @ 40), (N/A, 20)
    (5170 - 5250 @ 40), (N/A, 20), NO-OUTDOOR
    (5250 - 5330 @ 40), (N/A, 20), NO-OUTDOOR, DFS
    (5490 - 5710 @ 40), (N/A, 27), DFS
    (57240 - 65880 @ 2160), (N/A, 40), NO-OUTDOOR

##### iwlist channels ###################

eth0      no frequency information.

lo        no frequency information.

wlan0     13 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz

##### iwlist scan #######################

eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     No scan results

##### module infos ######################

[rtl8723ae]
filename:       /lib/modules/3.16.0-45-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723ae/rtl8723ae.ko
firmware:       rtlwifi/rtl8723efw.bin
description:    Realtek 8723E 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming  <chaoming_li@realsil.com.cn>
srcversion:     D38CC5BB27934DDBA952C9B
depends:        rtlwifi,rtl_pci,btcoexist
vermagic:       3.16.0-45-generic SMP mod_unload modversions 
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)

[rtl_pci]
filename:       /lib/modules/3.16.0-45-generic/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
description:    PCI basic driver for rtlwifi
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming  <chaoming_li@realsil.com.cn>
srcversion:     1BFD9F9E9693CB93908149A
depends:        mac80211,rtlwifi
vermagic:       3.16.0-45-generic SMP mod_unload modversions 

[rtlwifi]
filename:       /lib/modules/3.16.0-45-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming  <chaoming_li@realsil.com.cn>
srcversion:     9A94C1A2CE5E02B2F239836
depends:        mac80211,cfg80211
vermagic:       3.16.0-45-generic SMP mod_unload modversions 

[mac80211]
filename:       /lib/modules/3.16.0-45-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     315DCE1E2614AE1F38132D3
depends:        cfg80211
intree:         Y
vermagic:       3.16.0-45-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        C1:A3:1E:DB:9F:C4:C6:4E:2D:95:A7:FF:18:A6:73:D1:8C:AB:15:A6
sig_hashalgo:   sha512
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/3.16.0-45-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     D48679749A6B8B822E391CA
depends:        
intree:         Y
vermagic:       3.16.0-45-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        C1:A3:1E:DB:9F:C4:C6:4E:2D:95:A7:FF:18:A6:73:D1:8C:AB:15:A6
sig_hashalgo:   sha512
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[rtl8723ae]
debug: 1
disable_watchdog: N
fwlps: Y
ips: N
swenc: Y
swlps: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
probe_wait_ms: 500

[cfg80211]
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp
rtc
fuse

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

[/etc/modprobe.d/modesetting.conf]
options cirrus modeset=1
options mgag200 modeset=1

[/etc/modprobe.d/modprobe.conf]
options rtl8192ce ips=1
options rtl8192ce fwlps=0
options rtl8192ce swenc=1

##### rc.local ##########################

rfkill block bluetooth

exit 0

##### pm-utils ##########################

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x1969:0x1091 (alx)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'eth0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x10ec:0x8723 (rtl8723ae)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'wlan0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
# USB device 0x:0x (rtl8812au)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"

##### dmesg #############################

[ 2197.313311] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2197.313320] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x73ca9
[ 2197.313327] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2197.313333] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2197.313339] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2199.317197] rtl8723ae:rtl8723e_dm_bt_coexist():<0-0> [DM][BT], bt_dm_coexist start
[ 2199.317327] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> High Priority Tx/Rx (reg 0x770)=0(0)/2(2)
[ 2199.317339] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> Low Priority Tx/Rx (reg 0x774)=0(0)/0(0)
[ 2199.317347] rtl8723ae:rtl8723e_dm_bt_coexist_8723():<0-0> [BTCoex], 2 Ant mechanism
[ 2199.317353] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2199.317361] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x73e9e
[ 2199.317369] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2199.317374] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2199.317381] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2201.321503] rtl8723ae:rtl8723e_dm_bt_coexist():<0-0> [DM][BT], bt_dm_coexist start
[ 2201.321631] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> High Priority Tx/Rx (reg 0x770)=0(0)/1(1)
[ 2201.321642] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> Low Priority Tx/Rx (reg 0x774)=0(0)/0(0)
[ 2201.321650] rtl8723ae:rtl8723e_dm_bt_coexist_8723():<0-0> [BTCoex], 2 Ant mechanism
[ 2201.321657] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2201.321665] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x74093
[ 2201.321672] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2201.321678] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2201.321684] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2203.325434] rtl8723ae:rtl8723e_dm_bt_coexist():<0-0> [DM][BT], bt_dm_coexist start
[ 2203.325560] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> High Priority Tx/Rx (reg 0x770)=0(0)/2(2)
[ 2203.325566] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> Low Priority Tx/Rx (reg 0x774)=0(0)/0(0)
[ 2203.325571] rtl8723ae:rtl8723e_dm_bt_coexist_8723():<0-0> [BTCoex], 2 Ant mechanism
[ 2203.325574] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2203.325579] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x74288
[ 2203.325583] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2203.325586] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2203.325589] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2205.329433] rtl8723ae:rtl8723e_dm_bt_coexist():<0-0> [DM][BT], bt_dm_coexist start
[ 2205.329559] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> High Priority Tx/Rx (reg 0x770)=0(0)/1(1)
[ 2205.329566] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> Low Priority Tx/Rx (reg 0x774)=0(0)/0(0)
[ 2205.329571] rtl8723ae:rtl8723e_dm_bt_coexist_8723():<0-0> [BTCoex], 2 Ant mechanism
[ 2205.329575] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2205.329580] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x7447d
[ 2205.329584] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2205.329588] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2205.329591] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2207.333799] rtl8723ae:rtl8723e_dm_bt_coexist():<0-0> [DM][BT], bt_dm_coexist start
[ 2207.334041] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> High Priority Tx/Rx (reg 0x770)=0(0)/2(2)
[ 2207.334048] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> Low Priority Tx/Rx (reg 0x774)=0(0)/0(0)
[ 2207.334054] rtl8723ae:rtl8723e_dm_bt_coexist_8723():<0-0> [BTCoex], 2 Ant mechanism
[ 2207.334058] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2207.334064] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x74672
[ 2207.334069] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2207.334072] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2207.334076] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2209.337877] rtl8723ae:rtl8723e_dm_bt_coexist():<0-0> [DM][BT], bt_dm_coexist start
[ 2209.338003] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> High Priority Tx/Rx (reg 0x770)=0(0)/1(1)
[ 2209.338009] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> Low Priority Tx/Rx (reg 0x774)=0(0)/0(0)
[ 2209.338013] rtl8723ae:rtl8723e_dm_bt_coexist_8723():<0-0> [BTCoex], 2 Ant mechanism
[ 2209.338017] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2209.338022] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x74867
[ 2209.338026] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2209.338029] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2209.338032] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2211.342209] rtl8723ae:rtl8723e_dm_bt_coexist():<0-0> [DM][BT], bt_dm_coexist start
[ 2211.342337] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> High Priority Tx/Rx (reg 0x770)=0(0)/2(2)
[ 2211.342348] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> Low Priority Tx/Rx (reg 0x774)=0(0)/0(0)
[ 2211.342356] rtl8723ae:rtl8723e_dm_bt_coexist_8723():<0-0> [BTCoex], 2 Ant mechanism
[ 2211.342363] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2211.342371] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x74a5c
[ 2211.342378] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2211.342384] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2211.342390] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2213.346396] rtl8723ae:rtl8723e_dm_bt_coexist():<0-0> [DM][BT], bt_dm_coexist start
[ 2213.346517] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> High Priority Tx/Rx (reg 0x770)=0(0)/2(2)
[ 2213.346529] rtl8723ae:rtl8723e_dm_bt_bt_hw_counters_monitor():<0-0> Low Priority Tx/Rx (reg 0x774)=0(0)/0(0)
[ 2213.346537] rtl8723ae:rtl8723e_dm_bt_coexist_8723():<0-0> [BTCoex], 2 Ant mechanism
[ 2213.346543] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> [BTCoex] Get bt info by fw!!
[ 2213.346552] rtl8723ae:rtl8723e_dm_bt_inq_page_monitor():<0-0> [BTCoex], BT Inquiry/page started time : 0x0, cur_time : 0x74c51
[ 2213.346559] rtl8723ae:rtl8723e_dm_bt_is_2_ant_common_action():<0-0> Wifi idle + Bt idle, bt coex mechanism always off!!
[ 2213.346565] rtl8723ae:_rtl8723e_dm_bt_coexist_2_ant():<0-0> Action 2-Ant common.
[ 2213.346571] rtl8723ae:rtl8723e_dm_bt_is_same_coexist_state():<0-0> [DM][BT], Coexist state do not chang!!
[ 2223.670675] Using firmware rtlwifi/rtl8723fw_B.bin
[ 2223.672718] ieee80211 phy5: Selected rate control algorithm 'rtl_rc'
[ 2223.673582] rtlwifi: wireless switch is on
[ 2224.079562] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

########## wireless info END ############

What I did to generate this information:

  • I unplugged my usb-wifi adapter
  • Rebooted the computer
  • Ran the script
  • Plugged in the usb-wifi adapter
  • Pasted output to question.

About the drivers I could find:

  • I have tried the dropbox link but it doesn't work probably because of the -BT extension (would be my best guess - but make failed really bad and when that happens I have no clue what step B is).
  • I have succefully installed the driver at https://github.com/lwfinger/rtlwifi_new. I installed it with the following steps:

    • make
    • sudo make install
    • sudo modprobe rtl8723ae

The wifi does 'turn on' but iwlist scan wlan0 returns No scan results.

I have to say I'm not really a rocket scientist when it comes to wireless drivers but I would love to see it work. Thanks for any help and if you need more information please comment on this question and don't be a dick.

Updates

  • 2015-12-14 | Removed some of the routers listed in the script above + fixed the problem!
  • 2015-12-12 | Did a git pull as suggested in github issue. Also no effect since the only changes made were to the rtl8723be and not rtl8723ae driver.
  • 2015-12-12 | Put laptop really close to the router had no effect
  • 2015-12-08 | updated the wireless script without the usb wifi attached.
  • 2015-12-08 | Replied to a similair question on github: https://github.com/lwfinger/rtlwifi_new/issues/34
  • 2015-12-08 | ndiswrapper is not the culprit - updated the wireless script with the usb wifi attached.
  • 2015-12-08 | Will try the answer for ndiswrapper tonight.
  • 2015-12-08 | Also tried the rock and troy branches from the lwfinger github repo. No success yet.
  • 2015-12-07 | Updated the wireless_script result
  • 2015-12-06 | Succesfully installed rtlwifi and modprobed it from github link above - still it doesn't find any router..
3
  • 1
    What 'didn't work out' about the rtlwifi_new version? What were the errors? Maybe we can help.
    – chili555
    Dec 6, 2015 at 14:31
  • I updated the question to the current situation
    – Biketire
    Dec 7, 2015 at 17:35
  • @chili555 In short: iwlist scan wlan0 doesn't find any network.
    – Biketire
    Dec 8, 2015 at 19:54

2 Answers 2

2

I fixed it by doing the following:

I asked the developer of the rtlwifi driver to check if something was wrong. He told me the msi option was missing from the driver.

Steps to now setup a correct driver:

  1. Clone project: git clone git@github.com:lwfinger/rtlwifi_new.git (or you can just download .zip and extract somewhere)
  2. Build project: make; sudo make install
  3. Remove the old mod: sudo rmmod rtl8723ae
  4. Set the mod with the msi flag: sudo modprobe rtl8723ae msi=1

Tada. Wifi!

p. s. You can set option msi=1 for automatic loading by creating a file in /etc/modprobe.d

0

I believe ndiswrapper is interfering. Please open a terminal and do:

sudo apt-get purge ndiswrapper-common
sudo apt-get purge ndiswrapper-utils-1.9
sudo rm /etc/modprobe.d/ndiswrapper.conf

Reboot and let us see:

sudo iwlist wlan0 scan

You have the correct driver in place, so I assume the rtlwifi_new went just fine.

7
  • I'll try to see if that will work :) thanks for the response.
    – Biketire
    Dec 8, 2015 at 8:59
  • I'm sorrry but this doesn't work. I already removed both of the packages some long time ago. And the .conf file doesn't exist or was also already removed once. Thanks for the answer but it doesn't work. :(
    – Biketire
    Dec 8, 2015 at 18:56
  • "What I did to generate this information: - I unplugged my usb-wifi adapter - Rebooted the computer - Ran the script - Plugged in the usb-wifi adapter - Pasted output to question." The wireless script clearly shows the USB inserted and connected.
    – chili555
    Dec 8, 2015 at 19:25
  • Yes, I updated the script just now. Otherwise I have to take the usb-adapter out, run the script, put it back in and paste the information. I'm rather lazy when it comes to that. But I'll paste the info without the usb-adapter.
    – Biketire
    Dec 8, 2015 at 19:44
  • Does it see your network if you are very close to the router; one meter or so? Reference: ubuntuforums.org/showthread.php?t=2304607&page=2 post #19.
    – chili555
    Dec 8, 2015 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.