0

I have problems with my notebook's wifi (Intel Corporation Wireless 7265 (rev 59) on Ubuntu 14.04 (3.13.0-68-generic). Signal is shown often low (for no reason and same notebooks in Windows have much better performance) even though I am standing next to the router.

A friend of mine installed on his notebook (identical model brand etc...) Debian and it works perfectly. I asked him to send me modinfo iwlwifi output.

It seems to be, he has a newer driver and kernel version. Then I used diff to compare to mine. Should I try to install the new module (driver) on my current kernel or try to use newer kernel, which is not provided yet by the Ubuntu repositories? I do not want to play around with the kernel without any advice from experienced users and mess up my system.

1c1

< filename:
/lib/modules/3.13.0-68-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko


> filename: /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko

3c3

< author: Copyright(c) 2003-2013 Intel Corporation


> author: Copyright(c) 2003- 2014 Intel Corporation

18,21c18,24

< firmware: iwlwifi-7265-7.ucode

< firmware: iwlwifi-3160-7.ucode

< firmware: iwlwifi-7260-7.ucode

< srcversion: A45BAACCAD263355629DB7A


> firmware: iwlwifi-7265-9.ucode

> firmware: iwlwifi-3160-9.ucode

> firmware: iwlwifi-7260-9.ucode

> firmware: iwlwifi-8000-8.ucode

> srcversion: 3E4DCD8265C8E43DCA7B0EA

> alias: pci:v00008086d000024F4svsd00000030bcsci

> alias: pci:v00008086d000024F3svsd00000010bcsci

300,303c303

< vermagic: 3.13.0-68-generic SMP mod_unload modversions

< signer: Magrathea: Glacier signing key

< sig_key: xxx

< sig_hashalgo: sha512


> vermagic: 3.16.0-4-amd64 SMP mod_unload modversions

309c309

< parm: wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable, 2=enable (default: 0) (int)


> parm: wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable (default: 1) (int)

310a311

> parm: uapsd_disable:disable U-APSD functionality (default: Y) (bool)

314a316

> parm: fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)

  • Check out this link 》quora.com/… – DnrDevil Dec 6 '15 at 12:17
  • Thanks, I have found such solutions on the net but I would really like to know, if I can avoid it by simply and only installing new module on the standard kernel release for Ubuntu? – Genom Dec 8 '15 at 17:34
  • I would not recommend changing your kenel please check out mu answer here askubuntu.com/a/707042/459037 – DnrDevil Dec 8 '15 at 19:54
  • Thanks, so this was also my impression but I wasn't sure. I am going to try to upgrade module only. – Genom Dec 8 '15 at 20:09
0

It turns out to be it is highly unrecommended to upgrade kernel beyond what is provided by the Ubuntu repositories. And it is fairly simple to upgrade a single module with Backports. Backports are simply kernel modules provided by the Backports team of linux. Here you can find packages from various versions of the kernel and compile. Specifically, for the iwlwifi, here is a solution, which most likely also works for other modules. So far my wifi has been working without drops.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.