2

This question already has an answer here:

I am continuously attempting to install VirtualBox on Ubuntu 14.04, but I continue to receive errors.

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

After receiving this error, the Ubuntu sidebar and desktop disappear. I am able to resolve this issue by reinstall the desktop and unity. However, I am told elsewhere to purge and remove everything VirtualBox related and then reinstall. I have attempted to reinstall both through Ubuntu's Software Center, but have also gone the path of installing the .deb file from VirtualBox's website.

I have browsed through both Ubuntu and VirtualBox forums without success. Any help is much appreciated.

marked as duplicate by Takkat virtualbox Dec 6 '15 at 7:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

sudo apt-get install virtualbox should do it. I'm guessing you tried to install from a downloaded package or built from source code.

If you really want to install from source, you gotta have some dependencies installed (source):

sudo apt-get install linux-headers-generic build-essential dkms
sudo apt-get remove --purge virtualbox-dkms
sudo apt-get install virtualbox-dkms
  • ...you're awesome. That what the most simple solution among all the chaos. – user219454 Dec 6 '15 at 3:30
  • Out of curiosity, could you expand on why that worked where installing from the Ubuntu Software Center or downloading and install the file from the VirtualBox website did not work? – user219454 Dec 6 '15 at 3:31
  • 1
    The one in the software center may have missing dependencies (or someone may have forgotten to add dependencies). Or it may have tried to build from source (highly unlikely). Do mark as answer if it helped :) – pandalion98 Dec 6 '15 at 3:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.