1

On both machines I have

  • Desktop Sharing and
  • Remote Desktop Viewer (vinagre)

up and running. On both machines in Desktop Sharing Preferences I have enabled

  • Allow other users to view your desktop and
  • Allow other users to control your desktop

But almost nothing is working. The only thing that is working is that from the 14.04 machine's Remote Desktop Viewer I can see both of the machines on the network. Selecting the 12.04 machine results in a brief hang and then a "Connection closed" message. From the 12.04 machine I can't see any machines on the network from Remote Desktop Viewer so I can't even try to connect.

Any ideas how to start debugging this?

0

I've since moved on to a slightly different set up, but I believe I found the source of my problem, which turns out to be quite simple: The firewall on my host machine was set up to block almost all connections.

On the host machine I could see that the firewall was active by typing

sudo ufw status

To allow the remote desktop connection, I ran

sudo ufw allow from 192.168.1.[client] to 192.168.1.[host] port 5900

Then everything worked as advertised.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.