4

I had a dual boot system, W8 and Ubuntu 14.04.1 on my computer. WiFi worked just fine (bluetooth not).

Computer broke, and I had it a couple of months without use. After I fixed it (changed motherboard), everything worked fine, but then system updated and WiFi stoped working.

Recently I did a fresh install of OS (W8 and Ubuntu 14.04.3), but WiFi didn't work, in Ubuntu, not even on the liveCD (usb flashdrive). Tried liveCD with Ubuntu 14.04.1 but wireless didn't work either.

I suspect it is a kernel update issue.

"rfkill list all" shows wlan0 is hardblocked. If I press Fn+F12 (wifi on/off button), then rfkill switches from soft-blocked to yes or no, but remains hardblocked.

There is no wireless configuration on the BIOS.

WiFi works on W8.

Already tried the solutions posted here and nothing worked:

Ralink rt3290 wifi driver is not working in Ubuntu 14.04 problem!

Ralink rt3290 wifi driver is not working in Ubuntu 14.04 (similar as the previous one, but tried anyway in case driver source was different)

Here's some info from

"lspci -v":

01:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at c2510000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: rt2800pci

01:00.1 Bluetooth: Ralink corp. RT3290 Bluetooth
    Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter
    Flags: bus master, fast devsel, latency 0, IRQ 11
    Memory at c2500000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>

"iwconfig":

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

EDIT:

lsmod | grep wmi:

snd_rawmidi            32768  1 snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd                    86016  17 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
hp_wmi                 16384  0 
sparse_keymap          16384  1 hp_wmi
wmi                    20480  1 hp_wmi

Can anybody help me?

Thanks.

  • Please edit your answer to include the result of: lsmod | grep wmi Thanks. – chili555 Dec 6 '15 at 2:23
  • I've edited the post and added the result of lsmod | grep wmi. I've seen some asus_nb_wmi things on other post, so I looked for it, and aparently, wmi are related to the keyboard, and special keys. As I've mentioned, my WiFi on/off key does work, but works on the soft block, while nothing happens on the hard block. – Ariel Scarafia Dec 7 '15 at 2:09
  • Is there any improvement with: sudo modprobe -r hp-wmi followed by: sudo rfkill unblock all and finally: rfkill list all? – chili555 Dec 7 '15 at 2:13
  • Noup. Still the same... :/ – Ariel Scarafia Dec 7 '15 at 22:26
0

The good folks at (http://ubuntuforums.org/showthread.php?t=1621768) seems to have solved a quite similar issue by the following root command sequence

# rm /dev/rfkill
# reboot

You should probably review their thread first, to make sure it applies.

  • Thank you for trying to help, but I've read the post and tried this option, and it didn't work. /dev/rfkill re-apears every time I reboot. – Ariel Scarafia Dec 7 '15 at 2:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.