9

I ran xkill to force quit Chrome, and I clicked my desktop. The icons disappeared.

Is there a command that will get them back? I'd rather not restart.

I'm using GNOME and GDM.

0

4 Answers 4

11

The desktop icons are managed by file browser, on regular running try

$ ps ax | grep nautilus
 2464 ?        Sl     0:11 nautilus -n
 6390 pts/2    S+     0:00 grep --color=auto nautilus

From man nautilus

   -n
   --no-default-window
          Only create windows for explicitly specified URIs.

In this mode nautilus will not show a window, and it run like a daemon. So for you case use:

nautilus -n & disown
1
  • 1
    In Unity instead of Gnome Desktop, it also works without the -n flag and opening a normal Nautilus window just starts the separate daemon in background as well.
    – Byte Commander
    Dec 8, 2015 at 12:50
9

It turns out this can be fixed with Gnome Tweak Tool.

Using xkill on the desktop sometimes turns off the "Icons on Desktop" setting:

Turning this back on fixed it:

If the setting is not turned off, then just turning it off and on again brings them back.

My pronouns are He / Him

3
  • Wut ? xkill toggles show icons settings ? That's quite weird. Desktop should be managed by file browser not gsettings . . . Or maybe Gnome is just werid Dec 5, 2015 at 19:40
  • @Serg I guess it's weird :p
    – Tim
    Dec 5, 2015 at 19:40
  • 1
    @Serg, this should work too, as all it does it stops nautilus -n which is running in the background when off, and launch it if is on. this handled by gnome-settings-daemon or unity-settings-daemon.
    – user.dz
    Dec 5, 2015 at 20:42
2

All you have to do is open Nautilus and all will be back.

11
  • 1
    That does not work.
    – Tim
    Dec 5, 2015 at 20:54
  • 1
    I don't know how this is on Gnome, but simply launching Nautilus from the launcher or nautilus & disown from the terminal solves this problem perfectly well on Unity! @Sneetsher and @Tim
    – Byte Commander
    Dec 8, 2015 at 12:49
  • @ByteCommander , Excuse me Doug you deserve my up vote. I judged your answer on my own experience using an older release, However I confirm that your answer work as supposed on Ubuntu 15.10 for both Unity & Gnome Shell. Thank you ByteCommander for correcting me.
    – user.dz
    Dec 9, 2015 at 0:24
  • @Tim , Could you please review this because it seems to depend on the release. If you can mention here in a comment in which release did not work for you. It will be helpful for other users as the question is not for specific release, I think it does not deserve a down vote at least .
    – user.dz
    Dec 9, 2015 at 0:34
  • @sne the question says gnome, do you mean version?
    – Tim
    Dec 9, 2015 at 9:53
0

The previous answers did not work for me, but this command does for Kubuntu 18.04

kstart plasmashell

I hope this could helps others!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .