1

Question :

I would like to use a shortcut or any key to wake my computer from sleep mode using a Logitech wireless unifying keyboard (K800). I've already tried solutions from here and there.

Best case scenario, I would like the computer to wake only on keyboard events and not when the mouse linked to the same unifying device moves. But I'll take any valid solution that allows me to wake the laptop with one single shortcut or any key.

Best case scenario again, I would like to find a simple solution (not like this one)

Edit :

  • I just figured out that I can't even wake it with it's own internal keyboard (don't know if I messed up with some configuration trying to set up a workaround, or if it's always been the case.) So currently, only power button can wake that sleepy lazy laptop.
  • I've been through the same issue with all Ubuntu versions since 15.10, and still now on 17.04.

Solutions tried :

  • The solaar workaround answer on How do I get a wireless USB keyboard to to wake Ubuntu 13.10 from suspend? doesn't work.
  • That command have no impact on disable/enable status:

    sudo echo USB1 > /proc/acpi/wakeup

  • I've unsuccessfully tried to create wakeup files in, for instance (not sure to know where to put them):

    sudo echo enabled > /sys/bus/usb/devices/1-3.3/power/wakeup

  • I've unsuccessfully tried to add this in /etc/udev/rules.d/90-keyboardwakeup.rules

    SUBSYSTEM=="usb", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c52b" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

System informations

the receiver in lsusb results:

Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver

Result of lsusb -t :

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 2: Dev 4, If 0, Class=Video, Driver=, 480M
        |__ Port 2: Dev 4, If 1, Class=Video, Driver=, 480M
        |__ Port 3: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 3: Dev 5, If 1, Class=Human Interface Device, Driver=usbhid, 12M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 480M
    |__ Port 3: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 3: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 3: Dev 3, If 1, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 3: Dev 3, If 2, Class=Human Interface Device, Driver=usbhid, 12M

Result of cat /proc/acpi/wakeup

Device  S-state   Status   Sysfs node
P0P1      S4    *disabled
PEG0      S4    *disabled  pci:0000:00:01.0
PEG1      S4    *disabled
PEG2      S4    *disabled
PEG3      S4    *disabled
XHC1      S3    *enabled   pci:0000:00:14.0
EHC1      S3    *enabled   pci:0000:00:1d.0
USB1      S3    *disabled
USB2      S3    *disabled
USB3      S3    *disabled
USB4      S3    *disabled
EHC2      S3    *enabled   pci:0000:00:1a.0
USB5      S3    *disabled
USB6      S3    *disabled
USB7      S3    *disabled
HDEF      S4    *disabled  pci:0000:00:1b.0
RP01      S4    *disabled  pci:0000:00:1c.0
RP03      S4    *disabled
RP05      S4    *disabled
RP06      S4    *disabled
RP07      S4    *disabled
RP08      S4    *disabled
WLAN      S3    *disabled  pci:0000:03:00.0
RP04      S4    *disabled  pci:0000:00:1c.3
GLAN      S4    *disabled  pci:0000:04:00.0
                *disabled  platform:rtsx_pci_sdmmc.0
                *disabled  platform:rtsx_pci_ms.0
XHC     S3      *disabled
SLPB      S4    *enabled   platform:PNP0C0E:00

here is the result of grep c52b /sys/bus/usb/devices/*/idProduct (see marshcrfot answer)

/sys/bus/usb/devices/1-3.3/idProduct:c52b

Bios screenshots :

enter image description here enter image description here

  • 1
    Did you try to look for "wakeup events into" your BIOS? sometimes keyboard or mouse is inside... – Philippe Gachoud Dec 31 '15 at 16:08
1

Try the wakeup events like in this post into your BIOS! enter image description here

  • I don't have such option. I took some pictures of my BIOS menu if that could help. Regarding "USB" And "Wake Up" I only have "Wake On Lid Open: Enabled", "Legacy USB Support:Enabled", "XHCI Pre-Boot Mode:Auto" – mxdsp Jan 5 '16 at 14:13
  • My computer is a ASUS S550CM-CJ017H – mxdsp Jan 5 '16 at 14:15
  • just install the udev rule from this branch of solaar as described in the answer askubuntu.com/questions/440098/… – user1514631 Oct 16 '16 at 13:00
  • @user1514631 I installed the udev rule and it still doesn't work. – mxdsp Mar 19 '17 at 14:45
  • @mxdsp make sure you really have the udevd rule in /etc/udev/rules.d/42-logitech-unify-permissions.rules installed and that your user is in the plugdev group – user1514631 Mar 21 '17 at 18:48
1

But I'll take any valid solution that allows me to wake the computer, with one single shortcut, or any key.

A non-logitech wireless keyboard or mouse should work. I had the same problem with Ubuntu Mate 16.04LTS on a Gibabyte MiniPC with Logitech devices.

But i can wake with wireless devices that are non-Logitech, non-unifying receiver like Nulaxy ML11 2.4GHz Wireless Mouse (confirmed working out of the box can wake Ubuntu) or for a keyboard the Azio Vision Backlit Wireless Keyboard (KB506W) Updated Version (haven't confirmed can wake) or this LotFancy 2.4G Wireless Mini Backlit Keyboard Mouse Touchpad Combo (confirmed working out of the box can wake Ubuntu)

0

I think that you are asking for a logical impossibility. Regardless of the configuration of the system, when the system is asleep, no software is running. Wakeups have to be triggered by hardware interrupt (wired keyboard, wired mouse, wired LAN). Your wireless keyboard cannot provide the needed hardware signal. The wireless keyboard is "connected" to your computer by a method that requires the computer to be "UP" (powered on, not asleep) to communicate.

  • I'm not sure if a made that clear that the computer is not powered OFF, just asleep. Are you saying that you can't wake a computer from suspend mode from an USB device (the Logitech unifying receiver, actually) ? Considering the readings I already made, I think there is a misunderstanding (I'm not native speaker). EDIT : Also, it seems to work just fine for Windows users. The unifying receiver is USB wired physically to the computer. – mxdsp Dec 5 '15 at 15:39
  • By "asleep" do you mean "screen locked, computer running", "hibernated" or "suspended"? – waltinator Dec 5 '15 at 15:57
  • Well, i'm not sure how to translate it, but I only have one button for "suspend" , different from "restart" and "shut down" in Ubuntu 15.10. I don't think that hibernation is active on system. I guess it's" suspended" then – mxdsp Dec 5 '15 at 16:07
  • In French we call that "mode veille" (sleep mode). It's not lock, not hibernate, not shut down. Should I replace "spleep mode" by "suspend" In the title ? – mxdsp Dec 5 '15 at 16:11
  • Here is a list of solutions/posts solving the same issue : 1, 2, 3, 4, as said in my question, i tried these unsuccessfully – mxdsp Dec 6 '15 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.