1

I have a dual boot desktop running windows 10 (pro) and Ubuntu 14.04; everything was running fine until I updated windows 10 to version 1511 (the November 2015 update). Since the update my (wired) Ethernet connection no longer works under Ubuntu although it still works fine under windows.

The Ubuntu network manager keeps trying to establish a wired connection but after a while it just reports: disconnected - you're now offline. I noticed that a new network driver was installed during the windows update (see windows device properties). Could this have something to do with the problem I'm facing in Ubuntu?

In a fruitless attempt to solve my problem I installed the latest Intel networking driver for Linux, but this didn't solve anything. I suppose that the linux network driver update explains the "module verification failed: signature and/or required key missing - tainting kernel" line in the output of dmesg. The line wasn't there before I updated the Intel e1000e driver (original version was 2.3.2-k).

I've read a few posts regarding troubleshooting network problems and collected the output of a couple of terminal commands but my knowledge of Linux and networking is to limited to figure out the problem on my own ... Any help would greatly be appreciated.

me@desktop:~$ sudo lspci -v
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 04)
    Subsystem: ASUSTeK Computer Inc. Device 859f
    Flags: bus master, fast devsel, latency 0, IRQ 42
    Memory at f3300000 (32-bit, non-prefetchable) [size=128K]
    Memory at f3339000 (32-bit, non-prefetchable) [size=4K]
    I/O ports at f040 [size=32]
    Capabilities: [c8] Power Management version 2
    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [e0] PCI Advanced Features
    Kernel driver in use: e1000e

    ... (output for other devices was omitted as deemed irrelevant)

me@desktop:~$ lsmod
Module                  Size  Used by
pci_stub               12622  1 
vboxpci                23194  0 
vboxnetadp             25670  0 
vboxnetflt             27830  0 
vboxdrv               414452  3 vboxnetadp,vboxnetflt,vboxpci
uas                    27255  0 
usb_storage            66545  2 uas
rfcomm                 69509  0 
bnep                   19624  2 
bluetooth             446409  10 bnep,rfcomm
snd_hda_codec_hdmi     47548  1 
6lowpan_iphc           18702  1 bluetooth
nls_iso8859_1          12713  1 
joydev                 17393  0 
hid_generic            12559  0 
usbhid                 52616  0 
hid                   110426  2 hid_generic,usbhid
snd_hda_codec_realtek    77561  1 
snd_hda_codec_generic    69011  1 snd_hda_codec_realtek
nvidia               8591825  58 
snd_hda_intel          30469  5 
snd_hda_controller     30228  1 snd_hda_intel
snd_hda_codec         139719  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              17698  1 snd_hda_codec
intel_rapl             18783  0 
snd_pcm               104112  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
x86_pkg_temp_thermal    14205  0 
intel_powerclamp       18823  0 
kvm_intel             143630  0 
kvm                   456292  1 kvm_intel
snd_seq_midi           13564  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30876  1 snd_seq_midi
crct10dif_pclmul       14307  0 
eeepc_wmi              13151  0 
snd_seq                63074  2 snd_seq_midi_event,snd_seq_midi
crc32_pclmul           13133  0 
asus_wmi               24094  1 eeepc_wmi
sparse_keymap          13948  1 asus_wmi
ghash_clmulni_intel    13230  0 
mxm_wmi                13021  0 
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
aesni_intel           152552  0 
snd_timer              29562  2 snd_pcm,snd_seq
aes_x86_64             17131  1 aesni_intel
lrw                    13286  1 aesni_intel
gf128mul               14951  1 lrw
snd                    79468  21 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
drm                   311018  3 nvidia
glue_helper            13990  1 aesni_intel
ablk_helper            13597  1 aesni_intel
soundcore              15047  2 snd,snd_hda_codec
cryptd                 20359  3 ghash_clmulni_intel,aesni_intel,ablk_helper
mei_me                 19696  0 
parport_pc             32741  0 
shpchp                 37047  0 
mei                    87875  1 mei_me
serio_raw              13483  0 
lpc_ich                21093  0 
ppdev                  17671  0 
nct6775                55272  0 
hwmon_vid              12783  1 nct6775
wmi                    19193  2 mxm_wmi,asus_wmi
soc_button_array       12720  0 
coretemp               13441  0 
tpm_infineon           17131  0 
video                  20128  1 asus_wmi
mac_hid                13227  0 
lp                     17759  0 
parport                42348  3 lp,ppdev,parport_pc
psmouse               106767  0 
ahci                   34142  4 
e1000e                273604  0 
ptp                    19395  1 e1000e
libahci                32424  1 ahci
pps_core               19382  1 ptp

me@desktop:~$ dmesg | grep  "e1000e\|eth0"
[    0.534357] e1000e: module verification failed: signature and/or  required key missing - tainting kernel
[    0.534696] e1000e: Intel(R) PRO/1000 Network Driver - 3.2.4.2-NAPI
[    0.534698] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
[    0.534809] e1000e 0000:00:19.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    0.534822] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[    0.704888] e1000e 0000:00:19.0 eth0: registered PHC clock
[    0.704891] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 63:c1:2a:2c:b4:d5
[    0.704892] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
[    0.704927] e1000e 0000:00:19.0 eth0: MAC: 11, PHY: 12, PBA No: FFFFFF-0FF
[    2.685858] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[    2.788268] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[    2.788372] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    5.641432] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[    5.641459] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

me@desktop:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 63:c1:2a:2c:b4:d5  
          inet6 addr: fe80::61c1:2aff:fe2c:b4d5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:159 errors:0 dropped:1 overruns:0 frame:0
          TX packets:252 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:22346 (22.3 KB)  TX bytes:51674 (51.6 KB)
          Interrupt:20 Memory:f3300000-f3320000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:758 errors:0 dropped:0 overruns:0 frame:0
          TX packets:758 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:66984 (66.9 KB)  TX bytes:66984 (66.9 KB)

me@desktop:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

me@desktop:~$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 63:c1:2a:2c:b4:d5 brd ff:ff:ff:ff:ff:ff

me@desktop:~$ nmcli dev list iface eth0
GENERAL.DEVICE:                         eth0
GENERAL.TYPE:                           802-3-ethernet
GENERAL.VENDOR:                         Intel Corporation
GENERAL.PRODUCT:                        Ethernet Connection I217-V
GENERAL.DRIVER:                         e1000e
GENERAL.DRIVER-VERSION:                 3.2.4.2-NAPI
GENERAL.FIRMWARE-VERSION:               0.13-4
GENERAL.HWADDR:                         63:c1:2a:2c:b4:d5
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:19.0/net/eth0
GENERAL.IP-IFACE:                       
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.CONNECTION:                     not connected
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     1000 Mb/s
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{0}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   4891c95e-8447-4ed2-8c2c-138f8ab359c4 | Ethernet connection 1
WIRED-PROPERTIES.CARRIER:               on

me@desktop:~$ sudo lshw -class network
  *-network               
       description: Ethernet interface
       product: Ethernet Connection I217-V
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 04
       serial: 63:c1:2a:2c:b4:d5
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.4.2-NAPI duplex=full firmware=0.13-4 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:42 memory:f3300000-f331ffff memory:f3339000-f3339fff ioport:f040(size=32)

me@desktop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:    14.04
Codename:   trusty

me@desktop:~$ cat /etc/hosts
127.0.0.1   localhost
127.0.1.1   desktop

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

me@desktop:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
1

The problems appears to have solved itself somehow; windows installed another update and when I started Ubuntu afterwards the network connection worked again.

Whether updating the linux network driver was part of the solution or not is not clear to me, I literally have no clue what the problem was and what fixed it.

All I know is that it works again; case closed.

Update 2015-12-06: the problem still isn't solved, network connection in ubuntu only works when I shut down windows normally (with fast boot enabled). When windows shuts down without fast boot (SHIFT + shutdown or in case of a windows restart), the network connection in ubuntu doesn't work. I find this really strange and annoying but at least I have a workaround (boot to windows and shut it down with fast boot enabled).

1

you are correct ... I have the exact same issue ... windows update 1511 causes windows to not release the nic during the shutdown process ... so any for of restart or and form of shutdown without fast start enabled and windows will not complete the shutdown process thus "locking the nic to windows" and therefore not making it function without windows ... just another microsoft control mechanism and further proof they will not let you use the hardware you own ... but it gets better ... I decided to wipe my drive and completely get rid of windows ... however since I had disabled the fast start according to the instruction when I loaded my linux the nic would still not work even after the comp0lete wipe (using gparted) and reload ... so I unfortunately wound up reloading windows 10 in order to get the card released so that I could wipe the hdd and reload my choice of linux ... and per my research over the last month microsoft claims there is nothing wrong with the update 1511 and therefore has no intention of fixing it

1
  • I recently found out by accident that turning off the power completely for a minute of 2 (unplugging the power cord of just flipping the switch on my PSU) solves the problem of the nic being locked to windows. It's not necessarily very practical but it beats having to reinstall windows again just to release the nic ;) – Pieter Jul 10 '16 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.