0
  1. I edit blacklist.conf blacklist.conf
  2. I look what kernel modules are currently loaded nouveau

Update_1:

lspci -k | grep -EA2 'VGA|3D'

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
Subsystem: Pegatron Device 20c6
Kernel driver in use: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M] (rev a1)
Subsystem: Pegatron Device 20c6
03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

Update_2: Edited this file:

/etc/X11/xorg.conf

Section "Screen"
    Identifier  "Default Screen"
    DefaultDepth    24
EndSection        

Section "Device"
    Identifier  "Default Device"
    Driver  "nvidia"
    Option  "NoLogo"    "True"
EndSection

Section "Module"
    Load    "glx"
EndSection

lspci -k | grep -EA2 'VGA|3D'

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    Subsystem: Pegatron Device 20c6
    Kernel driver in use: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M] (rev a1)
    Subsystem: Pegatron Device 20c6
    Kernel driver in use: nvidia
  • did you reboot the system after? and what are you trying to do exactly? To use nvidia instead of nouveau ? – JoKeR Dec 5 '15 at 12:01
  • Why do you want to disable nouveau? You probably need to install proprietary drivers instead. Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. – Pilot6 Dec 5 '15 at 12:01
  • yes, I rebooted the system – Max Zueff Dec 5 '15 at 12:02
0

Mobility Nvidia GPU's cause headache because they are used with VGA controller which is embedded in Intel CPUs, as named Optimus Technology. I am able to activate Nvidia driver with editing /etc/X11/xorg.conf file after installation driver with apt-get, just installing nvidia driver by apt-get may not be enough.

0

You need to install Nvidia drivers by running:

sudo apt-get install nvidia-352

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.