After reinstalling Ubuntu 14.04 LTS, I got strange symbols in the terminal:

screenshot of strange symbols shown in terminal.

edited default profile settings.

Some fonts seem to be not correctly installed. What fonts are missing?

Perhaps "Inconsolata" font is the missing one, since I could not find it in the "Character Map". Thus I install this font:

sudo apt-get install fonts-inconsolata
sudo fc-cache -fv

Then I can see "Inconsolata" in "Character Map".

Gnome Character Map.

Nevertheless, I still got the ugly symbols in the terminal. And I've tried using the system fixed width font (Ubuntu Mono). Those "?" symbols were still there. Interestingly, those "?" do not appear in Terminator. Since I installed Powerline Powerline Ubuntu, the problem might come from the Powerline fonts.

Droid sans, Powerline symbols.

  • What's the selected terminal font? Ubuntu's default console font is called “Ubuntu Mono”. Can you post a screenshot of the terminal emulator's profile settings? Does the same font look normal in other applications (e. g. the default character map gucharmap)? – David Foerster Dec 5 '15 at 9:59
  • @DavidFoerster, thank you for the quick reply! I've updated my question :) – Honig Dec 5 '15 at 11:57
  • did you try different font like Ubunty Mono? – Edward Torvalds Dec 6 '15 at 6:13
  • @edwardtorvalds, yes, tried. Since I've installed Powerline, I guess the problem may come from Powerline fonts. – Honig Dec 6 '15 at 12:05

In the terminal emulator profile settings, either check the box Use the system fixed width font (red highlight), or select a font, that is currently installed on your system, through the button underneath (green highlight). Close and re-open the terminal emulator.

Gnome Terminal profile settings

I'm not entirely sure, whether this is the (only) reason for the broken font glyphs, but the selection of a non-installed font most likely causes some problem down the road.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.