I have downloaded the online installer from Steam's website. However, steam doesn't want to work after the installation process. I'm running Ubuntu 15.10 64bit. How can I get steam to work?


I have tried the following command: sudo apt-get install steam
Steam still does not work.


More details as requested.
I have tried the following command in the terminal: steam

This is the output:

Running Steam on ubuntu 15.10 64-bit  
STEAM_RUNTIME is enabled automatically  
[2015-12-06 21:38:07] Startup - updater built Nov  9 2015 18:23:22  
SteamUpdateUI: An X Error occurred  
X Error of failed request:  BadValue (integer parameter out of range for operation)  

Image of the error

  • Are you using open source drivers for a Radeon or NVidia card? FWIW, Valve only officially supports Steam on the LTS Ubuntu.
    – dobey
    Dec 5, 2015 at 2:16
  • can you edit your post and add the output of the command steam
    – Neil
    Dec 7, 2015 at 1:48
  • @Neil It encounters an error. I have edited my post with the error.
    – GSM-S
    Dec 7, 2015 at 2:49

2 Answers 2


Run these commands in terminal :


mv $HOME/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 $HOME/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6.bak


mv $HOME/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6 $HOME/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6.bak

This solution may have solved steam errors like yours in other posts, e.g. this Post.
As it has not been marked as solved yet, please tell me if this works or not.

  • Thank you! This worked! I had to use both of the commands however to make Steam work.
    – GSM-S
    Dec 7, 2015 at 3:24

Try installing it directly from the Ubuntu Software Center app.

Some info on this page as well, though may be out of date. But it has references to some resources that can help.


  • Ubuntu software centre doesn't have it. :(
    – GSM-S
    Dec 5, 2015 at 4:38
  • Weird, now I see that - it shows up in the USC for me but if I click it then it's not found. Try going to a terminal window and running sudo apt-get install steam
    – user367250
    Dec 5, 2015 at 14:40
  • I have attempted this as well. Steam updated, but it still does not start.
    – GSM-S
    Dec 7, 2015 at 2:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.