4

I recently installed Ubuntu 15.10, and now Aptitude is showing only a link to the package's homepage instead of a full description that it used to show in my previous installation of 14.04. What can I do to get these descriptions?

enter image description here

The output of apt-cache policy

stefan@desktop:~$ apt-cache policy 
Paketdateien:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu/ wily/main Translation-en
 500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu/ wily/main i386 Packages
     release v=15.10,o=LP-PPA-graphics-drivers,a=wily,n=wily,l=Proprietary GPU Drivers,c=main
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu/ wily/main amd64 Packages
     release v=15.10,o=LP-PPA-graphics-drivers,a=wily,n=wily,l=Proprietary GPU Drivers,c=main
     origin ppa.launchpad.net
 500 http://security.ubuntu.com/ubuntu/ wily-security/universe Translation-en
 500 http://security.ubuntu.com/ubuntu/ wily-security/restricted Translation-en
 500 http://security.ubuntu.com/ubuntu/ wily-security/multiverse Translation-en
 500 http://security.ubuntu.com/ubuntu/ wily-security/main Translation-en
 500 http://security.ubuntu.com/ubuntu/ wily-security/multiverse i386 Packages
     release v=15.10,o=Ubuntu,a=wily-security,n=wily,l=Ubuntu,c=multiverse
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ wily-security/universe i386 Packages
     release v=15.10,o=Ubuntu,a=wily-security,n=wily,l=Ubuntu,c=universe
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ wily-security/restricted i386 Packages
     release v=15.10,o=Ubuntu,a=wily-security,n=wily,l=Ubuntu,c=restricted
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ wily-security/main i386 Packages
     release v=15.10,o=Ubuntu,a=wily-security,n=wily,l=Ubuntu,c=main
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ wily-security/multiverse amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-security,n=wily,l=Ubuntu,c=multiverse
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ wily-security/universe amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-security,n=wily,l=Ubuntu,c=universe
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ wily-security/restricted amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-security,n=wily,l=Ubuntu,c=restricted
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ wily-security/main amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-security,n=wily,l=Ubuntu,c=main
     origin security.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-backports/universe Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily-backports/restricted Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily-backports/multiverse Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily-backports/main Translation-en
 100 http://de.archive.ubuntu.com/ubuntu/ wily-backports/multiverse i386 Packages
     release v=15.10,o=Ubuntu,a=wily-backports,n=wily,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu/ wily-backports/universe i386 Packages
     release v=15.10,o=Ubuntu,a=wily-backports,n=wily,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu/ wily-backports/restricted i386 Packages
     release v=15.10,o=Ubuntu,a=wily-backports,n=wily,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu/ wily-backports/main i386 Packages
     release v=15.10,o=Ubuntu,a=wily-backports,n=wily,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu/ wily-backports/multiverse amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-backports,n=wily,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu/ wily-backports/universe amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-backports,n=wily,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu/ wily-backports/restricted amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-backports,n=wily,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu/ wily-backports/main amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-backports,n=wily,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/universe Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/restricted Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/multiverse Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/main Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/multiverse i386 Packages
     release v=15.10,o=Ubuntu,a=wily-updates,n=wily,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/universe i386 Packages
     release v=15.10,o=Ubuntu,a=wily-updates,n=wily,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/restricted i386 Packages
     release v=15.10,o=Ubuntu,a=wily-updates,n=wily,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/main i386 Packages
     release v=15.10,o=Ubuntu,a=wily-updates,n=wily,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/multiverse amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-updates,n=wily,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/universe amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-updates,n=wily,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/restricted amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-updates,n=wily,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily-updates/main amd64 Packages
     release v=15.10,o=Ubuntu,a=wily-updates,n=wily,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily/universe Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily/universe Translation-de
 500 http://de.archive.ubuntu.com/ubuntu/ wily/restricted Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily/restricted Translation-de
 500 http://de.archive.ubuntu.com/ubuntu/ wily/multiverse Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily/multiverse Translation-de
 500 http://de.archive.ubuntu.com/ubuntu/ wily/main Translation-en
 500 http://de.archive.ubuntu.com/ubuntu/ wily/main Translation-de
 500 http://de.archive.ubuntu.com/ubuntu/ wily/multiverse i386 Packages
     release v=15.10,o=Ubuntu,a=wily,n=wily,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily/universe i386 Packages
     release v=15.10,o=Ubuntu,a=wily,n=wily,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily/restricted i386 Packages
     release v=15.10,o=Ubuntu,a=wily,n=wily,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily/main i386 Packages
     release v=15.10,o=Ubuntu,a=wily,n=wily,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily/multiverse amd64 Packages
     release v=15.10,o=Ubuntu,a=wily,n=wily,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages
     release v=15.10,o=Ubuntu,a=wily,n=wily,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily/restricted amd64 Packages
     release v=15.10,o=Ubuntu,a=wily,n=wily,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
     release v=15.10,o=Ubuntu,a=wily,n=wily,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
Mit Pinning verwaltete Pakete:
stefan@desktop:~$ 

And the output of cat /etc/apt/sources.list |grep -v \#

stefan@desktop:~$ cat /etc/apt/sources.list |grep -v \#

deb http://de.archive.ubuntu.com/ubuntu/ wily main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ wily main restricted

deb http://de.archive.ubuntu.com/ubuntu/ wily-updates main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ wily-updates main restricted

deb http://de.archive.ubuntu.com/ubuntu/ wily universe
deb-src http://de.archive.ubuntu.com/ubuntu/ wily universe
deb http://de.archive.ubuntu.com/ubuntu/ wily-updates universe
deb-src http://de.archive.ubuntu.com/ubuntu/ wily-updates universe

deb http://de.archive.ubuntu.com/ubuntu/ wily multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ wily multiverse
deb http://de.archive.ubuntu.com/ubuntu/ wily-updates multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ wily-updates multiverse

deb http://de.archive.ubuntu.com/ubuntu/ wily-backports main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ wily-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu wily-security main restricted
deb-src http://security.ubuntu.com/ubuntu wily-security main restricted
deb http://security.ubuntu.com/ubuntu wily-security universe
deb-src http://security.ubuntu.com/ubuntu wily-security universe
deb http://security.ubuntu.com/ubuntu wily-security multiverse
deb-src http://security.ubuntu.com/ubuntu wily-security multiverse
6
  • 1
    You have not described what you did already to get them back, this would help. I would start with removing local config if it exists rm ~/.aptitude/config if it exist, if that does not help purge and re-install aptitude: sudo apt-get purge aptitude sudo apt-get install aptitude – Requist Jan 5 '16 at 20:16
  • @Requist: Removing local config did not help, and purging and reinstalling aptitude didn't help either. – Stefan Hamcke Jan 6 '16 at 15:11
  • interesting.. could you add the outcome of apt-cache policy ? – Requist Jan 6 '16 at 15:59
  • @Requist: I've added it to my post. – Stefan Hamcke Jan 6 '16 at 16:11
  • ok, and the output of cat /etc/apt/sources.list |grep -v \#? – Requist Jan 6 '16 at 16:21
1

Attempting a somewhat unsatisfactory answer, starting with 3 observations:

  1. you are not alone
  2. the aptitude version changed from 0.6.11 (in Ubuntu 15.04) to 0.7.3
  3. /usr/share/aptitude/NEWS lists the changes between the two versions, and for 0.7.2 we read under "internal changes"

Improve retrieval of source package information with (upcoming) APT 1.1.
Thanks to David Kalnischkies for the suggestion and implementation advice.

Information about source package and version will be in the binary cache, and available via the VerIterator (ver.SourcePkgName() and ver.SourceVerStr()) and it is much faster than parsing the package record.

What caught my eye was "will be in the binary cache" as something that will be true for APT 1.1, but the APT version right now is only 1.01 in Ubuntu 15.10

So it looks like it will just take some patience until you find the full descriptions again.

1
  • Thanks for your answer. So I will probably just have to wait for the next version. I hope it will be in Ubuntu 16.04 then. – Stefan Hamcke Jan 12 '16 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.