0

Since some weeks/months, my wifi may not connect for a long time (or after several wifi off-on) or it may at random times drop the connection and not start again until I switch it off and on again.

It may be from some minutes to some hours and it happens almost every time I turn my laptop back on from sleep (but also under normal circumstances).

Sometimes it may even show that it is still connected but this may not be the case.

When the problem occurs, the particular or more wi-fi access points may not be shown in the Wi-Fi Networks list.

It is not Access-Point dependent, it happens always, everywhere.

Here you may find some debug info I could gather: https://gist.github.com/MakisH/bf670963ee7557fbb42b

I use a Dell Studio 1558 laptop with Broadcom BCM43224 802.11a/b/g/n and Ubuntu 14.04.3. It didn't have such problems for a long time before.

Edit 13/12/2015: I remembered that a few months ago I tried to resolve a similar problem with my wifi, that I had posted here: Stopped finding a specific wifi network, live works fine

I also saw that I have two drivers for this device. In the "Additional Drivers", if I click "Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)", I can't even see my network (it used to work a long time ago) and generally I can see less networks. When I tried to find out what driver I am using, I got:

ls /sys/class/net/wlan0/device/driver/module/drivers
pci:wl

Currently I have selected "Do not use the device" and it works, but with the problem I describe in this question. Again:

ls /sys/class/net/wlan0/device/driver/module/drivers
bcma:brcmsmac

Which driver should I use? I guess the STA from the bcmwl-kernel-source, but then I have the problem that I don't even see my network...

  • May be unrelated but it does suggest not using channels outside 1-12 on the Debian wiki: wiki.debian.org/brcm80211 , you are on 13. – Progrock Dec 4 '15 at 11:12
0

This is not a permanent solution. But you can try this on your temporary solution. Put your lap on standby or hibernate mode, than open it again it will connect and working fine.

I know this is not a permanent solution. but it may help you for temporary recovery. So please don't Vote it down.

  • Actually you remind me to mention that this problem occurs almost always after sleep. It also happens under normal circumstances too, though. Thanks for trying to help! :) – MakisH Dec 4 '15 at 10:27
  • try this solution by reinstalling your wifi drivers. askubuntu.com/questions/55868/… – Kvvaradha Dec 4 '15 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.