6

Whenever the focus is on a text edit element, the key combination ctrl+alt+b brings up a weird on screen keyboard:

screenshot

I wanted to remove this binding (or delete the program), but I can find neither! As you can see in the image, the OSK is not Florence nor Onboard, nor any I could find online. A reverse google image throws no results.

I'm using Ubuntu 14.04.3 LTS, with openbox as window manager, and no DE.

7
  • Can you find out the application's command by following the question here: askubuntu.com/q/508527/367990 ?
    – Byte Commander
    Dec 3, 2015 at 20:28
  • Thanks, I hadn't thought of that, but the problem is that xdotool is reporting the name of the application where I've pressed ctrl+alt+b, I can't get the name of the little dialog with the OSD. grepping ps for "osd","key", or "virtual" doesn't yield any unnormal process. Dec 3, 2015 at 20:41
  • Well - might it be that the on-screen keyboard is a part of your editor application then? Does it happen on other programs as well? Or only there? Which one is it?
    – Byte Commander
    Dec 3, 2015 at 20:44
  • It happens on every program, as I said "whenever the focus is on a text edit element" Dec 3, 2015 at 20:47
  • Also, when I click "Latin" it switches to other layouts: latin, fullwidth, hirakana, greek, russian, symbol table, etc. Maybe this has something to do with openbox? It seems more like low level. Dec 3, 2015 at 20:53

4 Answers 4

5

The way to solve the issue but keep fcitx:

sudo vim /usr/share/fcitx/addon/fcitx-vk.conf 

add to the file

Enable=false

logout, login again

1
  • Worked, only the key was named Enabled, not Enable (Ubuntu 18.10).
    – Odysseas
    May 22, 2019 at 13:44
3

I had the same problem. Probably it's caused by fctix, which is some software, which supports input methods. For some reason, I couldn't successfully kill this process from terminal. I found it in graphical system monitor and killed the process from GUI. After that, while typing Ctrl+alt+B, weird keyboard wasn't displayed anymore. You can also try to remove this software.

Instruction showing how to remove fctix can be found here: http://installion.co.uk/ubuntu/precise/universe/f/fcitx/uninstall/index.html

Uninstalling:

sudo apt-get remove --auto-remove fcitx

Purging config data:

sudo apt-get purge --auto-remove fcitx
2
  • Perfect, this did the trick! Feb 1, 2016 at 16:04
  • 1
    If you need fcitx like me, you can just disable the Virtual Key Board addon via Fcitx Configuration.
    – xuchunyang
    Oct 8, 2016 at 11:25
3

I met the same problem. I tried piotr.wittchen's solution and it did work, but I couldn't input Chinese any more after that.

So, I reinstalled fcitx, and modified its Global Config in Input Method Configuration. Choose Show Advanced Options, and make Switching Virtual Keyboard empty. This solved the problem for me.

2

You can disable this by below steps: Settings->Fcitx config->Global config->Show advanced Options(Left bottom) -> Switching Virtual Keyboard -> Pressing Esc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.