Using every method possible I'm unable to change my laptop brightness.. It's stuck on super max brightness.. Using the slider in the "screens" window int he control panel doesnt do anything, and using the fn keys doesn't do anything...

Some info about my system:

  • laptop is a MSI VR420

  • Running ubuntu 11.10

  • video card is an integrated intel card

  • Used to work when I ran ubuntu 10.10 and earlier versions (not sure if it worked out of the box or if I inadvertly fixed it in previous versions while installing lots of other packages)

  • Brightness slider on the "screen" window doesn't do anything, "dim when on battery -power" doesnt do anything

  • When I use the Fn+F4/F5 keys to adjust brightness there is a popup showing that its receving the input, but I can only go from between 0 brightness and max brightness.. (that is what the output is showing, the brightness does not change though)

  • when attempting to change the brightness with Fn+F4/F5 my dmesg log reports "ACPI: Failed to switch the brightness"

Here are some outputs from some terminal commands, not sure if any of this is useful or not..

lspci - http://pastebin.com/EimZSGs3

ls /sys/class/backlight/*/brightness will output:


cat /sys/class/backlight/intel_backlight/brightness => 0 (when I use the Fn+F4/F5) this will change betwene 0 and, but the actual brightness doesn't change)

cat /sys/class/backlight/intel_backlight/max_brightness => 1

lsmod | grep ^i915 => i915 505108 3

Here is the list of things I've tried through searching google.....

  • Edit /etc/default/grubGRUB_CMDLINE_LINUX_DEFAULT: acpi_osi=Linux, acpi_backlight=vendor, nomodeset. (as well as several different combinations of these settings being on or off)

  • Edit /etc/X11/xorg.conf (file doesn't exist on my system)

  • Edit /proc/acpi/video/VGA/LCD/brightness (file doesn't exist)

  • sudo setpci -s 00:02.0 F4.B=XX (does nothing)

  • xbacklight -set XX (does nothing)

I've tried about everything with no luck... The only thing I haven't tried is adding the ppa that someone suggested here: Unable to change brightness in a Lenovo laptop .... However according to the notes on the ppa.. all of the changes that are in the ppa are now actually apart of 11.10 and the ppa is only for people with 11.04..

Does anyone have any ideas for me?

edit:by setting acpi=off in my /etc/default/grub file I was about to get my Fn+F4/F5 keys to work, also "dim when display to save power" now makes my laptop dim when on battery power.. the dimness slider however still doesn't do anything.. also xbacklight doesn't do anything stil or any of the other methods...

The thing i don't get is why setting acpi=off makes my Fn+F4/F5 keys work? Isn't acpi supposed to be enables the backlight to be dimmed? does anyone know what ubuntu is deciding to do behind the scenes when acpi=off? Does anyone know what/if any features I might be losing with it off?

  • Maybe you can change the brightness with xrandr.
    – Nimmermehr
    Commented Oct 22, 2011 at 9:14
  • doesn't xbacklight simply just use randr? (btw I did just install it and tried a bunch of different things in it, nothing seems to do anything)
    – Danny
    Commented Oct 22, 2011 at 15:46
  • in my /etc/default/grub file i added acpi=off to the commandline (a suggestion I found on google).. after rebooting my fn+f4/f5 keys actually worked to change the brightness... Though I'm not sure what features I might have lost by doing that or why exactly it worked.. I thought acpi was what allowed for brightness to be changed?.... Is ubuntu falling back to some kind of non acpi system to emulate acpi controls? I'd kind of like to figure out whats going on here..
    – Danny
    Commented Oct 22, 2011 at 16:15
  • Danny, can you provide a link to the location you read about acpi=off? I'm having issues changing the brightness on my screen as well. I have an HP dv7-6135dx. Thanks
    – jairo
    Commented Nov 10, 2011 at 21:05

5 Answers 5


In /etc/default/grub change:



GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

run sudo update-grub in the terminal.


sudo setpci -s 00:02.0 F4.B=XX (does nothing)

This assumes that you have the 945GM chipset and that it is pci-device 00:02.0

setpci is a hammer so if you find the correct chipset then you can get the datasheet and find the register responsible for dimming the display. BTW, I too am having the same issues with my HP-dv7-6157nr:) I'll post a result once I find it. I'm finding that I'm just having to write a bunch of old school scripts to get things to work:(


I have this problem with my Lenovo's which use Nvidia graphics cards. To resolve the issue I add the following lines to my xorg.conf, if I don't have an xorg.conf I create it. Replace the 'Driver' "nvidia" option with your manufacturer which in this case seems to be "intel".

sudo nano /etc/X11/xorg.conf (Paste the below)

Section "Device"
    Identifier     "Device0"
    Driver         "intel"
    Option         "RegistryDwords" "EnableBrightnessControl=1"

As mentioned above I have seen this problem with nvidia cards and cannot confirm the problem with intel and therefore cannot gurantee the above fix will resolve your problem but it's worth a try :)

All the best.



acpi=off causes my Fn keys not to work. However the below command helped me fix my issue: 100% brightness and some Fn keys to work, like WiFi on/off on laptop

Ao add this to /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor"
  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – RolandiXor
    Commented Apr 4, 2012 at 14:39

Download compiz config settings manager from the software center. when you open it look under Accesibility and go to opacity,saturation, brightness section.goto the brightness tab and enable the keyboard shortcut icon. when its enabled for increase/decrease brightness a popup menu will show up. press grab key combination and choose a combo that you want. when i did it my function button and brightness key did'nt work well, so I used the control key and my brightness buttons. but it still has to be adjusted in each individual screen. so its not perfect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .