I've just installed and configured a house server with Ubuntu 10.04 (LTS). Everything works fine, but I have a problem:

I want to connect and share with Samba a USB Disk formatted in ext4. I tried to mount the unit but I couldn't do it. I want to have mount this unit all the time, so if I reboot the server I can still access to the unit.

I have Samba installed and Working


  • Please elaborate in detail.how usb disk be in ext54 format it always in fat32 – Deepak Rajput Oct 22 '11 at 8:38
  • 2
    How exactly did you try to mount it and what is was the error message? You might want to have a look at these answers: askubuntu.com/questions/46588/how-to-automount-ntfs-partitions/… and askubuntu.com/questions/50357/… and askubuntu.com/questions/54321/… – con-f-use Oct 23 '11 at 9:54
  • Can you clarify. Are you talking about an external hard drive, over USB? (If so, what capacity?) What OS was used to format the drive? – david6 Nov 19 '11 at 23:48
  • This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! – Tachyons Apr 5 '12 at 19:44

Can you please post the output of:

mount /dev/sdXY /mnt

Where sdXY is the device you are trying to mount.

If you dont know what is the device you want to mount, connect it to the USB port, wait 5 seconds e type the command


You will see the new attached USB device (Example: sdb1)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.