How can I set the default terminal used in Unity?

I would like to use the Ctrl+Alt+T hotkey to start a non-default terminal. The default terminal is gnome-terminal.

Where can I change the default terminal value?

12 Answers 12

up vote 118 down vote accepted

For 12.04 and newer

gconf is now deprecated - http://en.wikipedia.org/wiki/GConf - and gsettings can be used in its place.

gsettings set org.gnome.desktop.default-applications.terminal exec 'terminal'

Where terminal is the command you would use to open it from the terminal.

  • I have installed terminator as terminal and uninstalled gnome-terminal but the command you suggested does not work for me. – Gaurav Agarwal Apr 9 '14 at 9:59
  • Works fine for me on 13.10. – Martin Apr 10 '14 at 11:29
  • 2
    I use Terminator as my main terminal, but after running this command, ctrl+alt+T does not work anymore at all. – user1880405 Sep 21 '14 at 16:09
  • 2
    @TorbenGundtofte-Bruun replace konsole with gnome-terminal – Rumesh Apr 25 '15 at 11:39
  • 1
    Still works for Ubuntu 16.04 – geekQ Jun 11 '16 at 12:02
sudo update-alternatives --config x-terminal-emulator
  • 5
    While this is a great answer to the question (and generally a preferrable way to change a default program IMHO) this may not be the 'weapon of choice' in all circumstances. To elaborate: I wanted to set guake terminal as default but it never showed when trying to do so by update-alternatives. – FuzzyQ Aug 4 '12 at 17:13
  • 1
    Also, You can edit directly to the script xdg-open :) sudo gedit `which xdg-open` – iegik Aug 6 '12 at 9:40
  • This does not change the shortcut command result, as clearly stated in the question, I don't get why it has so many upvotes. – m3rosss Jul 30 '17 at 11:00
  • It works for me on Ubuntu 17.04. I installed terminology and it became the Ctrl+Alt+T terminal. Ran update-alternatives and changed it back to gnome-terminal, and it worked immediately. – rjh Dec 19 '17 at 15:21

Only in Ubuntu 11.10 or earlier! For newer versions see LucaB answer!

Open a terminal (e.g. gnome-terminal)

Run the next command:

gconftool --type string --set /desktop/gnome/applications/terminal/exec <YOUR-TERMINAL>

e.g.:

gconftool --type string --set /desktop/gnome/applications/terminal/exec terminator

Done :).

  • 5
    This doesn't fix it for me. When I start Htop via its .desktop file (which specifies Terminal=True), it starts in Gnome Terminal no matter what. Is there yet another place to change the default terminal emulator? – Ryan Thompson May 4 '12 at 1:05
  • 2
    THE CORRECT ANSWER IS BELLOW! – Gerep Sep 10 '13 at 13:22
  • @gerep My answer is correct, because the question defined exactly the Ubuntu version: 11.10. Of course in the newer versions the gconftool is deprecated, so not this the right solution. – Regisz Sep 12 '13 at 9:28

To change the shortcut and not default termainal,

  1. search for keyboard
  2. go to shortcuts and custom shortcuts
  3. press the plus sign to add new shortcut (in this case terminator)
  4. when told that the shortcut ctrl+alt+t is already in use press "reasign"

search for keyboard add new shortcut reasign

  • Exactly what I was looking for, thank you! – John Hamelink Sep 26 '12 at 0:44
  • 2
    does not work for me. – Gaurav Agarwal Mar 23 '14 at 18:26
  • +100 for being the easiest to understand and the one that has withstood the test of time. – Brandon Bertelsen Dec 23 '16 at 18:03

Try to change option x-terminal-emulator via "ALternatives Configurator" app.

for ubuntu you can use the command below:

sudo update-alternatives --config x-terminal-emulator

It will list all the terminal options you have installed and then you can pick (by the number) the one you want.

  • 2
    a little bit helping: 'Alternatives Configurator' is 'galternatives' – Regisz Oct 26 '11 at 14:20

To configure the default terminal in gnome you need to install dconf-tools (sudo apt-get install dconf-tools).

After that you can use the gsettings to set your favorite terminal emulator.

Lets say your favourite terminal emulator is termite.

Install it with sudo apt-get install termite

After that type this command

gsettings set org.gnome.desktop.default-applications.terminal exec termite

Since termite does not take any arguments (or it does, depends on what you do with it, you can set them this way) use this to set empty or set the exec-args for the terminal you need

gsettings set org.gnome.desktop.default-applications.terminal exec-arg ""

After this termite will be your default terminal emulator.

  • there is another way outlined in askubuntu.com/questions/70540/… – krumpelstiltskin Nov 16 '11 at 21:15
  • Its the same thing, really does not mater, this way uses the replacement tool for gconf – Bruno Pereira Nov 16 '11 at 21:22
  • exec-arg didn't work for me unfortunately. I was trying to start terminal in fullscreen mode. The only option that helped was specifying the option in configuration. I am using terminator – Tim Oct 29 '12 at 20:57

Try

sudo update-alternatives --config x-terminal-emulator
  • 1
    Hmm, on second thought, this doesn't seem to be updating it. – Kris Harper Oct 26 '11 at 19:21
  • This works perfectly. Thank you. – pedrorolo Apr 7 '13 at 15:56

The update-alternatives system is a Debian thing, but Gnome run on many more distributions, so it has its own way to define preferred applications.

You can set default terminal through the utility gnome-default-applications-properties, also accessible through gnome-control-center as Preferred Applications.

Alternatively you can set the gconf registry key /desktop/gnome/applications/terminal/exec.

However, it is not guaranteed that all applications provided by Gnome, like nautilus, will respect this setting, or rather use their own settings.

This worked in Ubuntu 13.10

gsettings set org.gnome.desktop.default-applications.terminal exec terminator
  • This is what worked for me on Ubuntu 14.04 with terminator – trueCamelType Sep 3 '16 at 2:23

If you go to the Keyboard shortcuts, you will notice under the Launcher section that Ctrl+Alt+T is tied to the "Launch Terminal" action. I haven't tested it yet, but you can create a Custom Shortcut to your preferred Terminal, and bind that shortcut to it instead.

OK, one weird thing is that the compiled gnome-terminal with the patch will not work if your DISPLAY var is :0 , works flawlessly if DISPLAY=localhost:0.

So you can edit /usr/bin/gnome-terminal/wrapper and add this:

ENV{"DISPLAY"}="localhost:0";

right before the exec line.

Subsequently you can use /usr/bin/gnome-terminal/wrapper as the launcher!

sudo update-alternatives --set x-terminal-emulator <terminal-path>

For example:

sudo update-alternatives --set x-terminal-emulator /usr/bin/tilix

If you want to do it with interactive mode or check paths:

sudo update-alternatives --config x-terminal-emulator

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.