7

I recently bought a new desktop computer and installed Ubuntu 15.10 64-Bit on it. By default, the nouveau driver is in use for my Nvidia Geforce GTX 960, but I cannot watch any video on Youtube with more than 360 pt, so I installed the proprietary Nvidia drivers. The boot process, however, does not get past the Ubuntu logo with the blinking circles below it, and I cannot do anything in that situation except for pressing Ctrl+Alt+Del to reboot. This happens with the driver from the standard repository (nvidia-352 which is installed via the software-properties-gtk interface) as well as with the driver from the Xorg-Edgers PPA (nvidia-304 on which the nvidia-current package depends). I would try the driver from the official Nvidia page, but it requires me to disable the nouveau driver first and I don't know how to do that.

Does anyone have an idea on how to get the driver working?

Update (12/04/15): With the boot options quiet splash nomodeset, the system boots normally. After some file system checks, the Nvidia logo appears and then the login screen appears. The output of lspci -v | grep -A 14 NVIDIA

01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device 8678
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 138
    Region 0: Memory at de000000 (32-bit, non-prefetchable) [size=16M]
    Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Region 3: Memory at d0000000 (64-bit, prefetchable) [size=32M]
    Region 5: I/O ports at e000 [size=128]
    [virtual] Expansion ROM at df000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia

01:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)
    Subsystem: ASUSTeK Computer Inc. Device 8678
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin B routed to IRQ 17
    Region 0: Memory at df080000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

02:00.0 USB controller: ASMedia Technology Inc. ASM1142 USB 3.1 Host Controller (prog-if 30 [XHCI])
    Subsystem: ASUSTeK Computer Inc. Device 8675
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes

suggests that the nvidia module is in use, which I can confirm with lsmod. Still, I can watch Youtube videos only in 144p.

Update (12/07/15): It finally works. I cannot say precisely what made it work. I installed two packages: nvidia-common and nvidia-modprobe, updating all installed packages in the process. I also ran nvidia-xconfig which created a xorg.conf in my /etc/X11/ folder. Finally I added quiet splash nomodeset to my grub.cfg (as opposed to adding them in the grub menu at each boot). After rebooting, I was able to watch videos in HD. I then deleted the xorg.conf and also purged the two packages I had just installed, and it still works. So either the updating of my installed packages or the boot parameters in the grub.cfg made the difference.

Update 2 (12/07/15): So I removed the quiet splash nomodeset from my grub.cfg (and I didn't add them in the boot process either), and it still works. So I have no idea what changed the situation. Let's just see if this change is permanent now :-)

  • 1
    I regularly check the status of the questions and the issues I am trying to help getting fixed. As it seems, everything is working fine now. I am glad that you have got your problem solved. Sometimes things just have to settle down. When you install the drivers, the configuration of the settings occur automatically. Maybe something did not work as it should in your earlier attempts. The graphics drivers installation experience depends a lot on the specific hardware and the current kernel. Hope I could help you with my answer and assistance to achieve the solution - enjoy ubuntu experience ! :) – cl-netbox Dec 13 '15 at 11:53
5
+50

First you have to uninstall all NVIDIA drivers and repositories you have already installed before.

When the GRUB boot menu appears - Highlight the Ubuntu menu entry and press the E key.
Add the nouveau.modeset=0 parameter to the end of the linux line ... Then press F10 to boot.

When the login screen appears - press Ctrl+Alt+F1.

Enter your user name and your password - then execute :

sudo apt-get install ppa-purge
sudo apt-get purge nvidia*  
sudo ppa-purge ppa:xorg-edgers/ppa
sudo reboot  

Now install the latest official NVIDIA drivers 358.16 which support your GEFORCE GTX 960 GPU.

When the GRUB boot menu appears - Highlight the Ubuntu menu entry and press the E key.
Add the nouveau.modeset=0 parameter to the end of the linux line ... Then press F10 to boot.

When the login screen appears - press Ctrl+Alt+F1.

Enter your user name and your password - then execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358
sudo reboot
  • I'll try that ... – Stefan Hamcke Dec 2 '15 at 17:11
  • With nouveau.modeset=0 the system hangs the same way as when the Nvidia drivers are installed, so I could only perform the steps without that option. – Stefan Hamcke Dec 2 '15 at 17:19
  • @StefanHamcke : The parameter disables nouveau only for the time you are uninstalling the old drivers and installing the new drivers. After installation of the new NVIDIA drivers you do not have to add the parameter anymore. If it doesn't work, perform the installation without adding the boot parameter. – cl-netbox Dec 2 '15 at 17:22
  • 1
    The problem is that I cannot even access the tty1 via Ctrl+Alt+F1 when the problem occurs. – Stefan Hamcke Dec 2 '15 at 17:27
  • 1
    @StefanHamcke : Try to boot with the parameter nomodeset instead of nouveau.modeset=0. – cl-netbox Dec 2 '15 at 17:30
2

With this I refer to the link given here :

Has anyone successfully installed CUDA 7.5 on Ubuntu 14.04.3 LTS x86_64?

There is Method A and Method B explained by me :

First of course clean the non-suiting installations with :

sudo apt-get install ppa-purge

sudo apt-get purge nvidia*

sudo ppa-purge ppa:xorg-edgers/ppa

sudo reboot

For place reasons only Method A here :

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt-get update

sudo apt-get install nvidia-355 nvidia-prime

or is this working ?:

sudo apt-get install nvidia-358 nvidia-prime ?

sudo reboot

Happy coding and merry x-mas.

1

This will remove the nouveau driver and will allow you to install the proprietary driver from the Nvidia website

sudo apt-get -y autoremove xserver-xorg-video-nouveau --purge

Here is the proprietary Nvidia driver for your specific GPU:

wget http://us.download.nvidia.com/XFree86/Linux-x86_64/352.63/NVIDIA-Linux-x86_64-352.63.run

Then you just have to run the command below and it will install the Nvidia driver:

sudo sh NVIDIA-Linux-x86_64-352.63.run

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.