I clean-installed Ubuntu 11.10 today, and then installed VirtualBox. This required me to add myself to the vboxusers group, and since 11.10 seems to no longer have a graphical app to add users to a group, I ran the following command:

sudo usermod -G vboxusers stephane

This is a problem. I now see what I should have run instead is:

sudo usermod -aG vboxusers stephane

The end result is I'm no longer in the groups I should be in. Including whatever group is required to run "sudo". When I run any command as sudo now, I get the following:

$ sudo ls
[sudo] password for stephane: 
stephane is not in the sudoers file.  This incident will be reported.

Is there a way to fix this, or do I need to re-install from scratch again?

  1. During boot, press and hold the left Shift key, and you should see the GRUB menu.

  2. Select the entry containing (recovery mode) and wait.

  3. You should now be presented with a menu. Select:

    remount    Remount / read/write and mount all other file systems 

    and wait for your file systems to get mounted with read/write permissions, then press Enter.

    If this option doesn't appear or won't work, you can instead choose the root option and use the following command to mount the system partition:

    mount -o remount /

    You can check out which is your system partition with fsck command or by viewing /etc/mtab.

    After successfully running the mount command (i.e. no error messages), proceed directly to step 5 below.

  4. After choosing the remount option, the menu comes up again. Select:

    root       Drop to root shell prompt
  5. Now enter one of the following commands to re-add your user to the admin group (for Ubuntu 11.10 and earlier):

    adduser <USERNAME> admin

    or to the sudo group (for Ubuntu 12.04 and later):

    adduser <USERNAME> sudo
  6. Reboot and you should be able to use sudo again.

  • 3
    If you don't see the "remount" menu, you can select "fsck" first, it will remount you filesystem to read/write. After that, you can add your user in root mode. – Jiejing Zhang Sep 19 '13 at 22:59
  • 1
    This worked for me, except I had to mount the filesystem using the command mount -o remount,rw /. – Passuf Apr 7 '16 at 16:53
  • This works perfectly. Also, it looks like a big security issue. I guess you should disable this feature on sensible machines? -- When in recovery mode, I am never able to reboot. I always have to use reboot -f. – Romain Vincent Jun 1 '18 at 7:38

If root login is enabled on your system just drop terminal via Control+Alt+F1 without log in to X. Log in as root and then just add the desired user to admin group (for Ubuntu 11.10 and earlier):

adduser desired_user_name admin

For Ubuntu 12.04 and later, add the user to the sudo group:

adduser desired_user_name sudo

If you did not enable root login just choose recovery mode from Grub and then try root shell.

Root Shell

Mount file system as read-write:

mount -o rw,remount /

After that you can again add your desired user to the admin (or sudo) group.

  • But I can't access sudo from my user! – Jamie Hutber Sep 6 '18 at 15:32

I've tried various combinations after doing the same thing as the remount menu option seems not to be in 12.10. I have tried everything else in this post from root. The last was

umount -a
mount -o -w /<path> /

This resulted in the filesystem still being ro due to a setting in fstab to boot ro on filesystem error I think, with it stating it seemed to be ro after mount.

I finally managed it with

mount -o rw,remount /

Although I am not sure how this is different from the previous set of commands.

After applying this variation, adding a user to the admin (11.10 and ealrier) or sudo (12.04 and later) group is done the same way:

adduser username admin    # 11.10 and earlier
adduser username sudo     # 12.04 and later

Old question but happened to me too (Ubuntu 14.04).

I was unable to log into recovery mode and gain access to a root shell, as many answers here and elsewhere describe: the root shell access from GRUB seems to be password-protected.

So I solved the problem this way:

  1. boot on a live usb stick
  2. open a shell
  3. access the main HD Linux filesystem (you can find its mounting point in the address bar of the GUI file explorer, usually after CTRL-L). cd into it.
  4. edit the file etc/group (say with nano etc/group or anything else)
  5. find the "sudo" line. Should look like sudo:x:27:admin,bob,alice
  6. add yourself to the sudo line, comma separated

Of course, this implies that the file etc/sudoers still holds the line

%sudo   ALL=(ALL:ALL) ALL

meaning that all members of the group sudo have total control. First check that.

Worked uneventfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.