3

After pressing "suspend" in unity menu computer (desktop) suspends, power LED turns off, disks are stopping. Then in less than second it resumes.

Searching gives solutions like this laptop fails to suspend or hibernate (wakes up after 2-5 seconds without user interaction) They do not work:

cat /proc/acpi/wakeup 
Device  S-state   Status   Sysfs node
PCI0      S5    *disabled  no-bus:pci0000:00
PEX0      S5    *disabled  pci:0000:00:1c.0
PEX1      S5    *disabled
PEX2      S5    *disabled
PEX3      S5    *disabled  pci:0000:00:1c.3
PEX4      S5    *disabled
PEX5      S5    *disabled
HUB0      S5    *disabled  pci:0000:00:1e.0
USB0      S3    *disabled  pci:0000:00:1d.0
USB1      S3    *disabled  pci:0000:00:1d.1
USB2      S3    *disabled  pci:0000:00:1d.2
USB3      S3    *disabled  pci:0000:00:1d.3
USBE      S3    *disabled  pci:0000:00:1d.7
AZAL      S5    *disabled  pci:0000:00:1b.0

Dmesg:

[  717.606585] PM: Preparing system for sleep (mem)
[  717.709011] Freezing user space processes ... (elapsed 0.001 seconds) done.
[  717.710813] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[  717.712130] PM: Suspending system (mem)
[  717.712153] Suspending console(s) (use no_console_suspend to debug)
[  717.713093] sd 1:0:0:0: [sdb] Synchronizing SCSI cache
[  717.713242] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[  717.713437] sd 1:0:0:0: [sdb] Stopping disk
[  717.727539] parport_pc 00:03: disabled
[  717.727654] serial 00:02: disabled
[  717.740078] sd 0:0:0:0: [sda] Stopping disk
[  718.127674] PM: suspend of devices complete after 415.242 msecs
[  718.128544] PM: late suspend of devices complete after 0.865 msecs
[  718.129206] pcieport 0000:00:1c.3: System wakeup enabled by ACPI ///////////////////////////////////even was turned off
[  718.144109] PM: noirq suspend of devices complete after 15.562 msecs
[  718.144439] ACPI: Preparing to enter system sleep state S3
[  718.144897] PM: Saving platform NVS memory
[  718.144934] Disabling non-boot CPUs ...
[  718.145265] Broke affinity for irq 27 ///////////////////////////////////???wtf
[  718.146308] smpboot: CPU 1 is now offline ///////////////////////////////////seems suspended
[  718.164300] ACPI: Low-level resume complete ///////////////////////////////////waking up
[  718.164300] PM: Restoring platform NVS memory
[  718.164300] Force enabled HPET at resume
[  718.164300] Enabling non-boot CPUs ...
[  718.164300] x86: Booting SMP configuration:
[  718.164300] smpboot: Booting Node 0 Processor 1 APIC 0x1
[  718.188478]  cache: parent cpu1 should not be sleeping
[  718.188778] CPU1 is up
[  718.190379] ACPI: Waking up from system sleep state S3
[  718.204401] PM: noirq resume of devices complete after 13.322 msecs
[  718.204749] PM: early resume of devices complete after 0.320 msecs
[  718.204995] usb usb2: root hub lost power or was reset
[  718.205000] usb usb3: root hub lost power or was reset
[  718.205047] usb usb4: root hub lost power or was reset
[  718.205054] usb usb5: root hub lost power or was reset
[  718.205102] pcieport 0000:00:1c.3: System wakeup disabled by ACPI
[  718.206597] rtc_cmos 00:01: System wakeup disabled by ACPI
[  718.207118] serial 00:02: activated
[  718.207657] parport_pc 00:03: activated
[  718.220841] sd 0:0:0:0: [sda] Starting disk
[  718.220863] sd 1:0:0:0: [sdb] Starting disk
[  718.325632] r8169 0000:03:00.0 eth0: link down
[  718.371695] ata2.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
[  718.371697] ata2.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
[  718.371699] ata2.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[  718.372167] ata1.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
[  718.372169] ata1.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
[  718.372171] ata1.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[  718.381179] PM: resume of devices complete after 176.425 msecs
[  718.381482] PM: Finishing wakeup.

If network cable is disconnected from computer or internet cable is disconnected from switch suspend works OK.

There is a forwarded port to that machine and torrent app working. But there are problems with suspend before logging in into profile when torrent starts.

It looks like some broadcast messages are interrupting suspend via LAN.

  • Wake up by ring is turned off in BIOS.
  • Selecting S1 or S3 suspend states in BIOS have no effect.
  • I re-installed clean 15.10 and this has no effect.
  • This problem was also on 15.04
  • The same is on 4.2.0-16, -18 kernel

Please point some issues to search. Thanks.

System 15.10 4.2.0-19-generic #23-Ubuntu SMP Wed Nov 11 11:39:30 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux.

0

There was a BIOS issue. Found on Gigabyte site (MB manufacturer) fixes for that problem for newer revisions of my MB. Flashing BIOS with newer firmware of my revision version have no effect. Asked manufacturer for support.

Problem does not relate to the OS.

Russian Ubuntu forum topic http://forum.ubuntu.ru/index.php?topic=270386.0

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.