0

I've changed my harddisk, to a bigger one. The old one had Ubuntu 14.04 with full disk encryption (luks). The new hard disk has a fresh install of Ubuntu 15.10 without disk encryption.

I need however to boot the old hd to get some files from some programs (if possible boot it and not just file access). I've tried to take out the new hd and just put in the old hd, assuming it would boot. Well it didn't. I'm guessing, this has to do something with the GRUB boot loader, since I see in the boot option menu in my bios an entry for ubuntu.

What can I do to boot my old hd?

0

You don't really want to boot from the old HD, do you? Just read files/data from it?

Once the old HD is connected, and you're running your new Ubuntu (or a live ISO/DVD/USB) the "Disks" program (gnome-disks) should be a nice graphical way to see if the old HD's partitions are encrypted with LUKS, unlock/open them (assuming you have a passphrase), and then mount them.

You could use terminal tools too, like these:

  • And maybe your drive uses LVM, so you might need to add in commands like these too (from help.ubuntu.com's Resize Encrypted Partitions ):
    • sudo apt-get install lvm2 to install the lvm tools
    • sudo vgscan --mknodes
    • sudo vgchange -ay these two should recognize/activate the lvm, I think to a new name, something in /dev/mapper/
  • lsblk to quickly see the drives/partitions attached
  • cryptsetup isLuks <device> to check if the partition/device is a LUKS volume
  • cryptsetup luksOpen <device> <name> to open/unlock a LUKS device & set up a mapping <name>
  • mount /dev/mapper/<name> /mountpoint to mount it at some /mountpoint

But "Disks" is pretty nice, when it works.

  • If possible I'd like to boot to the old hd, to export some setting from a few programs, which I have forgotten to export. I have allready tried to mount it (as you described with cryptsetup luksOpen and the mount command. Unfortunately terminal then tells me that the device is busy. I suspect, that is, because it tries to map it at /dev/mapper/ubuntu--vg-root, which of course exists by the currently booted 15.10 (of the new disk) – wawa Nov 30 '15 at 18:15
  • Maybe it's got linux volume management... aka LVM... And maybe there's more detailed error messages in dmesg & /var/log/syslog? – Xen2050 Nov 30 '15 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.