3

I downloaded a new Popcorn Time from popcorn-time.se and I don't know how to install a tar.gz file. I extracted the folder that is in tar.gz and then tried to run command sudo ./install but there in no command found.. What should I do? How to install this "new" Popcorn Time source file?

5

Those are directly the files you need to run the program. For opening Popcorn Time, just run from the extracted folder:

./Popcorn-Time

However, if you want to know where to save all those files with the other programs, a good place would be /usr/share.
So, let's say the folder where you extracted the files is ~/popcorn-time. Then, you'll have to run this in a terminal:

# Copy the whole folder into /usr/share, using recursive option
sudo cp -r ~/popcorn-time /usr/share/popcorn-time
# Create a symlink to the binary file
sudo ln -s /usr/share/popcorn-time/Popcorn-Time /usr/bin/popcorn-Time

From now on, you'll be able to run popcorn-Time on the Terminal, and it'll open.

Finally, if you want to have an icon in the launcher, create a new file in your home directory, named popcorn.desktop, and write the following in it:

[Desktop Entry]
Name=Popcorn Time
Comment=Watch torrent movies instantly!
Exec=/usr/bin/popcorn-time
Terminal=false
Type=Application
  • Yes, but when i run ./Popcorn-Time i get this message: ./Popcorn-Time: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory What now? – Milan97b Nov 29 '15 at 21:15
  • 1
    Just install the required library with sudo apt-get install libudev0:i386 and try again. – Hewbot Nov 29 '15 at 21:24
  • sudo apt-get install libudev0:i386 Reading package lists... Done Building dependency tree Reading state information... Done Package libudev0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libudev0' has no installation candidate – Milan97b Nov 29 '15 at 22:29
  • 2
    Manually download it (x86, x64), and install it with sudo dpkg -i libudev0_175-0ubuntu9_*. If any dependences errors appear, try after that sudo apt-get install -f. – Hewbot Nov 30 '15 at 19:22
2

When you unpack it, that already is the installation. It's no source file, it's a binary precompiled proprietary blob.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.