15

Using Oneiric 11.10 and Unity. I want to disable the context menu that appears with Alt+RightClick. Alt+RightClick is a much used shortcut in Blender. It's possible to remap keys in Blender, but I was hoping to be able to turn it off in Ubuntu so that Blender get scontrol. I update my Blender installation often, so it's more convenient not to have to change settings every time.

23

It's in CCSM ▸ General ▸ General options ▸ Key bindings ▸ "Window Menu" ( Alt + Button3)

Because disabling it does not work (at least in 12.04 and 12.10, probably earlier versions too), you will need to change the shortcut to something else, like Super + Button3.

enter image description here

Warning - You should be very careful when using ccsm; see this question for details.

  • 1
    The answer seems correct, but disabling the Window menu didn't have any effect for me. The menu still pops up in Blender. I am using Ubuntu 12.04 – HRJ Jul 18 '12 at 5:26
  • Just for the record, the contents of this answer also apply to Linux Mint 18 running with "Compiz".. – ZaLiTHkA Sep 7 '16 at 16:09
5

I have had the same problem and it's happened to me twice now. Both times I found this post and tried the suggestion of disabling the key binding and it does not work. However changing does work. I changed mine to shift-alt-rmb and it works fine.

3

Based on this site, overall:

  1. Install dconf-tools using sudo apt-get install dconf-tools
  2. Launch the app
  3. Navigate org -> gnome -> desktop -> wm -> preferences.
  4. Set value of mouse-button-modifier to: none will disable Alt + left/right/middle key at next login OR switch to other keys, such as <Ctrl>, <Super>, etc.

Hopefully this will help you out.

  • Ugh., that created a mess here. For those with similar problem, just restore the defaults: gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Alt>' – valk Jun 28 '13 at 5:14
  • well, he asked to disable the '<Alt>' key and i gave solution to disable it OR to change it with other key and of course using the same method to restore Alt key function is possible. – whale_steward Jun 29 '13 at 6:31
  • 1
    Changing <Alt> to none has the effect of treating left mouse click and drag as move window and right mouse click shows window menu. But entering <Super> is fine. – ivant Dec 26 '15 at 14:31
1

Hmm, there is a bug in ubuntu / unity related to hardcoded shortcuts. Thats why changing the shortcuts in settings does nothing.

For anyone who is searching solution for this problem - i think there is none for now (other than changing it in the ubuntu / unity code). You can only change the shortcut in blender, or you can use in blender shift+alt+rmb instead of alt+rmb, which is generally the same, but stands for add loop to selection (with shift), not select loop.

You can check the details about the ubunut bug here: https://bugs.launchpad.net/unity/+bug/1022743

0

There is bug and it can be disabled. Instead we need to assign it to some less or not used shortcut. So i used Crtl+Shift+Alt+Button2(middle button of mouse). There is no other option than mouse buttons to use. Though there are up to 20 button options, choosing button20 dummy will reset it to button3 or any of the button you set before.

Brief use Crtl+Shift+Alt+Button2 as shortcut

Note: And you need CCSM to do this.

0

It can be changed but you need to use CCSM -> general settings. Any other attept to disable/ change it failed. Hope someone will fix this soon. thnx for your time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.