1

I'm new to Ubuntu, installed Ubuntu 15.10 on my new laptop and everything seems to work fine, but …

Every time I try to install or deinstall something from softwarecenter (or via apt-get) this Error occurs (sorry it is in german):

Trigger für libc-bin (2.21-0ubuntu4) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 libc6-i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

I searched for similar questions and tried

apt-get autoclean
apt-get autoremove

and also tried to reinstall libc6-i386, it seems it is only half-installed (?)

$sudo apt-get install libc6-i386
libc6-i386 ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 2.272 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
dpkg: Fehler beim Bearbeiten des Paketes libc6-i386 (--configure):
 Paket libc6-i386 ist nicht bereit zur Konfiguration
 kann nicht konfiguriert werden (momentaner Status »half-installed«)
Fehler traten auf beim Bearbeiten von:
 libc6-i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

I don't know what to do next, just reinstall the whole system?

  • sudo apt-get install --reinstall libc6-i386 – A.B. Nov 29 '15 at 16:04
1

»half-installed« packages should be re-installed. Only one command:

sudo apt-get install --reinstall libc6-i386
  • worked for a dpkg-dev half-installed error as well - thanks – klequis Jun 9 '17 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.