4

I have install Ubuntu 15.10 to a USB drive, and while everything works mostly, I have to perform a lot of manual tasks after a reboot. I am using the computer for my media center.

There is a similar question with no answers

I am trying to have the ZFS pool loaded automatically after a reboot, but it does not load. If I do a zpool import MediaCenterData the system loads. In following troubleshooting:

$ apt-cache policy mountall
mountall:
  Installed: 2.54ubuntu1
  Candidate: 2.54ubuntu1
  Version table:
 *** 2.54ubuntu1 0
    500 http://ca.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
    100 /var/lib/dpkg/status

$ grep parse_zfs_list /sbin/mountall
<no output>

Working with /sbin/mountall

$ sudo mountall --verbose
mountall: Could not connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
$ sudo mountall --debug
mountall: Could not connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused$ apt-cache policy mountall
    mountall:
      Installed: 2.54ubuntu1
      Candidate: 2.54ubuntu1
      Version table:
     *** 2.54ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status

zpool status

$ sudo zpool status
no pools available

Import works

$ sudo zpool import MediaCenter
$ sudo zpool status

zpool status
  pool: MediaCenter
 state: ONLINE
  scan: none requested
config:

    NAME        STATE     READ WRITE CKSUM
    MediaCeter  ONLINE       0     0     0
      raidz2-0  ONLINE       0     0     0
        sda     ONLINE       0     0     0
        sdb     ONLINE       0     0     0
        sdc     ONLINE       0     0     0
        sdd     ONLINE       0     0     0
        sde     ONLINE       0     0     0
        sdf     ONLINE       0     0     0

errors: No known data errors

I do not know how to get the autoload to work? Does it have something to do with the fact I am running the / (root) off of a USB key?

Adding zpool import MediaCenter to the /etc/rc.local does work to remedy the issue.

  • can you post the content of your /etc/default/zfs and /etc/init/zpool-import.conf pls? – ostendali Dec 15 '15 at 16:13
  • That question does have an answer... – David Dec 15 '15 at 16:46
  • @DavidCole The previous question now has answers (Dec 10) they were posted, but did not when I asked this question. – Steven Scott Dec 16 '15 at 16:48
  • @ostendali Unfortunately, with no early direction available, I have since undone everything and installed FreeNAS. I still have frustrating issues which is why I was moving in the first place, but I did not keep an image to be able to post the information you asked for. I have noticed a couple people have upvoted and favorited this question, so maybe someone else has the same problem and can post their information. – Steven Scott Dec 16 '15 at 16:49
1
+100

From version 15.04 Ubuntu changed the default init process from Upstart to systemd, and a few things broke with this switch.

Some scripts needed to automount ZFS pools with systemd were missing. See the bug report at https://bugs.launchpad.net/ubuntu/+source/zfs-linux/+bug/1521952.

The good news is a bugfix was released on December 16th 2015 to the wily-updates universe repository. If this repository is enabled, you can update with the commands:

sudo apt-get update
sudo apt-get upgrade

FYI, mountall is a helper for Upstart, and is not used with systemd, hence the error "Could not connect to Upstart".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.