I ran openvpn client on my Ubuntu 14.04 successfully, but the sites with https (SSL protocol) cannot be opened while http sites seems working fine.

  • The OpenVPN server may be misconfigured - HTTPS over OpenVPN works here (14.04) – Thomas Ward Nov 29 '15 at 14:55
  • @ThomasW. others can connect httpS by this sever, they have MAC OS and Windows, also my android phones connect saccessfully! Just Ubuntu Can`t. – Milad Sobhkhiz Nov 29 '15 at 14:58
  • Hi there! can you confirm whether your Ubuntu system time/date is correct and up-to-date? I don't see any issue other than this if others can connect.. (: – AzkerM Nov 29 '15 at 16:00
  • @AzkerM my date and time setting are Ok and exact. – Milad Sobhkhiz Nov 29 '15 at 16:10
  • Do you get any specific errors or just the usual "cannot be displayed" sort of? – AzkerM Nov 29 '15 at 16:11

Since OpenVPN works at the network layer and is thus independent of ports (i.e. port 80 http vs. port 443 https) it is more probable that https is blocked by your OpenVPN endpoint. But please make sure that it is really the same host you try with http and https.


In case it will help someone, I got this error because I tried to connect to 2 VPNs at the same time. Usually I am using my own VPN that I have setup with OpenVPN on a Linux server to access Internet. For work, I had to use a VPN to access a few websites. However, I still want to keep my own VPN IP address to access most websites. So I tried to connect to the second VPN in an LXC container.

Only HTTP requests worked but HTTPS failed. The problem was fixed when I disconnected from my own VPN. In order to use 2 IP addresses at the same time, one for normal websites and the other for work websites, I used an SSH tunnel to my Linux server to browser normal websites through a proxy and used OpenVPN in an LXC container for work websites. It is also possible to use the OpenVPN connection as a proxy by creating an SSH tunnel to the LXC container.

At the moment I don't know if it is possible to use 2 VPNs at the same time without the HTTPS problem I had. I created a separate question for this issue: https://superuser.com/questions/1521812/use-a-proxy-or-another-vpn-before-connecting-to-a-vpn

  • Wouldn't a much simpler solution be to run your work VPN in a full blown VM? That's what i do using VirtualBox, although presumably kvm would do just as well. – pgoetz Feb 18 at 20:25
  • 1
    @pgoetz there is a way to make it work with LXC in the link from my answer. I prefer to avoid virtualization and use it as a last resort only if there is no lighter solution / without overhead. I mentioned this in the link: "instead of LXC, it could also be done with a Linux virtual machine in VirtualBox but the performance is better with LXC". – baptx Feb 25 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.