I have found that between decrypt disc and start of Xubuntu the USB ports sometimes work, sometimes does not. It is even more strange as the USB sometimes work after a restart. That is booting the computer does not make the USB-ports work, but after a restart they do.

As of the last week of December it seems the operating system have chosen to completely refuse to load the USB-ports. Not even restarting the computer brings the USB back to life. It is alive at boot from BIOS and works just until after the decryption and loading of the OS has begun. It means something happens when the decrypt hands over to the OS.

How can an operating system sometimes load USB drivers and sometimes not? Windows almost 100 % of the time does this without complaint. It should not even be an issue as USB is standard. If it were some new specialized port configuration I would understand, but USB?

Hmm, when I do dmesg | grep usb I get the following lines

[   43.448997]  [<ffffffff8154a094>] ? usb_control_msg+0xd4/0x110  
[   43.652852] usb 2-5: Device not responding to set address.  
[   43.857315] usb 2-5: device not accepting address 4, error -71  
[   43.968653] usb 2-5: new full-speed USB device number 5 using xhci_hcd  
[   43.992180] usb 2-5: New USB device found, idVendor=04ca, idProduct=300b  
[   43.992186] usb 2-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0  
[   46.428288] usb 2-5: USB disconnect, device number 5  
[   46.429599] usb 2-8: USB disconnect, device number 3  
  • 1
    Your username name....
    – Star OS
    Dec 7, 2015 at 20:38

1 Answer 1


It seems updating the kernel solved that problem and then some. Kernel update from 3.13->4.2-0-22

It solved the USB ports loading at each start and in addition the power management settings started to work which it did not do under the 3.13 kernel. What was actual and placebo we will never know.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .