2

I'm having real problems copying files from my phone (Samsung S5 mini) to my laptop (Kubuntu 15.10). I've tried many of the suggestions on other sites, such as

I can connect and browse files, but when I try to open or copy them, usually my CPU goes into overdrive for a bit, and then eventually gives up with this message: The process for the mtp protocol died unexpectedly. Occasionally, however, it does work. I have no idea what the difference is. Once, after a successful copy, I changed directory and tried to copy some other files, and the mtp connection died. Obviously, the setup here hadn't changed in the meantime.

mtp-detect gives the following result libmtp version: 1.1.9

Listing raw device(s)
Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
   Found 1 device(s):
   Samsung: Galaxy models (MTP) (04e8:6860) @ bus 4, dev 9
Attempting to connect device(s)
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.

I'd like to avoid things like adb/gvfs/fuser, since mtp should just work. I'll fall back to bluetooth if I really can't figure it out.

Other things which don't work:

  • Like this guy, I can't seem to connect at all through USB2.
  • If I switch the phone into camera mode it doesn't get detected at all.

Edit:

I've discovered a duplicate. That question was first, and it has one answer, but I think I provided a bit more information. What's the recommended procedure here? Should I close this as a dupe? Add a link from their question to here? Ideally I think I would put a bounty on the other question. (This added question might be a candidate for the meta section, but I would guess that it is a duplicate there, which seems like recursive meta and might make my brain explode.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.