First of all I should say that I have very limited computer knowledge so go easy on me. I have Ubuntu 15.10 installed on my laptop and I was trying to to install the driver for the Nvidia video card but an error kept popping up saying that the x server was on so the installation cannot be completed, so I disabled lightdm and went into the tty terminal and installed the driver (which was a .run file btw) from there, after I was done I started it again but the computer seemed to freeze so I rebooted it now I'm stuck in the login screen and whenever I type my password it just sends me back to the same screen. I tried going back into the tty and typing sudo start lightdm But it said that it failed to connect to socket /com/ubuntu/upstart. Btw sorry I'm using my phone so I can really format stuff properly. Update: typing

lspci -k | grep -EA2 'VGA|3D'

Yields this output

enter image description here

Again I apologize for taking a picture of the screen but I can't really do much from my laptop right now.

  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. It is a wrong way to install drivers this way.
    – Pilot6
    Nov 29, 2015 at 9:32
  • @Pilot6 did that Nov 29, 2015 at 9:47

2 Answers 2


You can install Nvidia driver for your adapter by running:

sudo apt-get install nvidia-352

You probably have some broken packages pending while you tried to install the Nvidia drivers. Try

sudo dpkg --configure -a

Then try to sudo service restart lightdm again.

  • Still the same issue :/ Nov 29, 2015 at 9:49

Not the answer you're looking for? Browse other questions tagged .