1

So after login the screen doesn't show any icons or anything else,its just background. I did some google searching and also on this site and i found this solution Unity doesn't load, no Launcher, no Dash appears . But the first solution doesn't do any good.

export DISPLAY=:0
sudo dconf reset -f /org/compiz/

and then

setsid unity

The above one however restored the icons and all but i couldn't open any drives and i face the same problem after restart. Please help I don't want to switch to windows or anything. P.S. I am noob

  • Have you tried other solutions on that post ? For instance logging in to console and rm -rf ~/.compiz-1 ~/.config/compiz-1 ? Also, if you really need GUI right now, make sure you are connected to internet, go to console and try to install another GUI, for instance sudo apt-get install gnome-shell or sudo apt-get install xubuntu-desktop . Once installed , run sudo service lightdm restart and on the login screen select the newly installed interface from a white cirle next to your username. – Sergiy Kolodyazhnyy Nov 29 '15 at 0:15
  • so, you enabled the unity plugin and it did no good? – mchid Nov 29 '15 at 3:34
  • @mchid yes i enabled plugin and it did nothing good. – tanay Nov 29 '15 at 4:02
  • @Serg Thank you for replying. I tried to remove the compiz-1 but it did nothing. So i installed gnome-shell and an interface popped up and i selected lightdm then i restarted lightdm and nothing happened on the screen. restarting also doesn't help. – tanay Nov 29 '15 at 4:04
  • @tanay are you on the site right now ? – Sergiy Kolodyazhnyy Nov 29 '15 at 4:26
0

I have ubuntu 16.04 and these are the steps that worked for me:

sudo apt-get update

sudo apt-get install –reinstall ubuntu-desktop

sudo apt-get install unity

rm -rf ~/.cache/compizconfig-1

sudo shutdown -r now

hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.