My son has an Ubuntu 14.04 lenovo issued by the school. Recently it won't connect to our home wifi but will connect at school and other wifi networks. I've been reading some of the fix-its listed here but so far none have worked. rfkill list shows no soft or hard blocking. I restarted the network manager but this didn't work. It tells me the signal is strong so it sees it. Password is correct. WPA2. It worked fine until 2 weeks ago. Help?

  • Try nano /etc/network/interfaces and see if it is set as a static ip address or set a dhcp ip address.
    – Alex Lowe
    Nov 28, 2015 at 18:19
  • see here and please post the info askubuntu.com/questions/425155/… thanks!
    – mchid
    Nov 29, 2015 at 3:22
  • All our other devices work on our network, which has not changed. Running Ubuntu 14.04 LTS. I deleted my network using network manager, shut down. Then rebooted, added my network again but still failed to connect. It can see the network. Odd thing is that network connections thinks that wired connection 1 was used under the ethernet heading but I was not using a LAN. Nov 29, 2015 at 21:23

1 Answer 1


I have intermittent wireless issues. In our last flat, my Mac wouldn't play well with one router, but would with another. I've had issues where a Windows laptop on the network would somehow interfere with my connectivity on another machine. When they connected I'd effectively get no access until they turned their P.C. off. A Windows P.C. at home frequently can't grab an address automatically (dhcp). Giving it its own fixed IP, and DNS server fixes that. I have another problem with my current router, another Windows box sometimes doesn't connect, even when others laptops do. A router reboot seems to fix that. At work one colleague had lots of problems, when we didn't. Sometimes the placement of the machine can really matter. There are many nuances. Do state your router if possible.

Some ideas:

Try other devices, do they connect okay to the same access point?

Try connecting with just the Lenovo.

Move the laptop.

Try connecting closer to the access point.

Try removing and re-adding the access point connection in Network Connections on the Lenovo.

Try a different protocol.

Scan locally with something like WiFi Radar to make sure your neighbour/s aren't on the same channel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.