0

Immediately following one of the latest Ubuntu system updates1, notifications about newly arrived mails stopped working. The corresponding plugin2 is still enabled, and I'm not aware of having changed any related configuration. Just to make sure, I've also checked the accounts' settings3 – but couldn't find anything related here. Neither can it be the "global notification daemon", as notify-send "Test" "Dummy notification" brings up the notification as expected.

I'm out of ideas where else I could check (some notification service that needs to be started explicitly but somehow failed? Notifications for other apps like Skype still pop up, and notify-send works as expected). I've already checked syslog for errors, but none are shown.

I'm running Evolution 3.4.2-1ubuntu3.1~stracciatellappa+precise1 on 12.04 here. I've checked for the mail-notification-evolution package, it's not installed4 – but as notifications worked before the last reboot, this cannot be the reason.

In case it matters: I'm using LXDE as desktop environment, but Gnome desktop is installed as well (though not selected as default). Again, as it worked in the past (before that last update/reboot), all required components should be available.

Update: I've just figured evolution-indicator should be responsible for notifications here. But there were no changes to that package either within the last year.

Any ideas what I could check/adjust to make notifications from Evolution work again?


1: I'm not sure which update exactly it was (there were no updates for Evolution itself); the issue started after the latest reboot. I assume it were the last kernel updates (3.2.0-94), but cannot tell for sure. Walking through the list of latest updates/installs in /var/log/apt/history.log doesn't reveal anything I'd recognize as related.

2: Edit › Plugins › Notifications for new mails

3: Edit › Settings › (Account_Name)

4: according to dpkg -l mail-notification-evolution it never has been installed – it doesn't even have an install candidate in the stracciatella PPA I've used to install Evolution 3.4.2 from quite some time ago; the package in the "standard repo" depends on Evolution < 3.3 and thus cannot be(en) used anyway

0

I'm not sure what finally did it – but currently, notifications are working again (and I hope they keep working):

  • as root, I've executed ln -s /usr/lib/evolution/3.2/plugins/* /usr/lib/evolution/3.4/plugins/1: If that has been the culprit, how did it work before? Neither Evolution nor the Evolution-Indicator have been updated in the past 12 months.
  • checked and "toggled" notification settings (each one twice, so I've ended up not changing them but triggering Evo to write them again), see note 1 in the question. Did that before, and it didn't help.
  • after the above, restarted Evolution. I did that before more than once without any effect on the issue.

Maybe it was the combination of tasks performed – or the two symlinked files in the plugin directory triggered some "re-configuration of plugins" in Evolution, solving the issue as a side-effect (which is what I assume).


1: evolution-indicator plugins were located in the 3.2 directory only – and were the only (two) files residing there

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.