1

Whenever I run Terminal or Ctrl-alt-T the terminal will open up for a split second and close itself. If I run gnome-terminal in X Term I get the same problem and the following message:

(gnome-terminal:12319): GLib-GIO-CRITICAL **: g_settings_get: the format string may not contain '&' (key 'monospace-font-name' from schema 'org.gnome.desktop.interface'). This call will probably stop working with a future version of git.

This happened after I changed the settings in the terminal, how do I fix it?

closed as unclear what you're asking by Pilot6, Ravan, hg8, Eric Carvalho, user364819 Nov 28 '15 at 21:40

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • What setting did you exactly change (and into what?) – Jacob Vlijm Nov 27 '15 at 16:23
2

For some reason, the key mentioned in the error message now contains a '&'. To see what its value currently is, open a console terminal, as this won't suffer from this bug: press CTRL + ALT + F1 (or F2...F6), login, and do:

gsettings get org.gnome.desktop.interface monospace-font-name

To change it, do

gsettings set org.gnome.desktop.interface monospace-font-name 'Ubuntu Mono 13'

(or any other value you like).

You can also run Software Center or Synapsis and install dconf-editor. This gives you a GUI that will let you view and change the value of the key.

  • 2
    You might want to add he should install dconf editor, since the terminal is inaccessible (I guess xterm will be affected as well) – Jacob Vlijm Nov 27 '15 at 16:59
  • 2
    Ah. Hadn't thought of that... (although the OP could always have started one on CTRL+ALT+F1 ;-) – Jos Nov 27 '15 at 17:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.