3

Out of the box, on a freshly installed Ubuntu 15.10, if I start a terminal, it will launch a window which fills almost the entire screen. It's not maximized in the window manager sense, but its dimensions are such that it fills the entire screen.

If from this window I launch gnome-terminal --geometry=80x24 I get a second terminal window which is also pseudo-maximized (the output from resize tells me 80x31 on my current screen).

What exactly is overriding my --geometry argument, and how do I disable it?

My end goal is to have applications launch at whatever dimensions their designers intended, so I am not looking for a fix specifically for gnome-terminal. The list of applications I actually care about is fairly short (Terminal, Emacs, Firefox, Thunderbird, Software Center, settings, etc) but I would like to avoid creating and maintaining a list of per-application "overrides for the override" and just get rid of the thing which does the geometry overriding in the first place.

The workaround at How can I start up an application with a pre-defined window size and position? is one prime example of the kind of clean-up I would like to avoid; that is the reason I am asking what causes this, rather than just how I can avoid it.

I would like to keep my other settings as much out of the box as possible. For example, disabling Unity completely will fix this, but also loses window title bars etc.

Requested output:

tripleee@vbvntv$ dconf dump /org/gnome/terminal/
[legacy/profiles:/:b1dcc9dd-5262-4d8d-a863-c897e6d979b9]
use-theme-transparency=false

[legacy]
schema-version=uint32 3
  • Could you add the output of dconf dump /org/gnome/terminal/ to your question and notify me afterwards with a comment, please? – Byte Commander Dec 1 '15 at 13:04
  • Not what I expected... :-/ – Byte Commander Dec 1 '15 at 13:20
  • Just a wild hunch, but what happens if you change or set/unset the default size for the terminal (profile preferences > set custom window size ) – Jacob Vlijm Dec 1 '15 at 14:07
  • @JacobVlijm Hmmm, the Terminal > Preferences > Profiles tab > Unnamed (current) shows 80x24 in "Initial Terminal Size", but if I create a new named profile with those settings and select it as the default for new windows, gnome-terminal creates a new window with the size I indicated in the profile. Now even after I deleted that profile, this setting is active (because, I guess, the "Unnamed" profile with these settings is now in active use, rather than just a dormant template ... or something like that). – tripleee Dec 2 '15 at 9:57
0

You could check if there is something relevant in environment – by looking at output of command env ran in the initial gnome-terminal.

Also, file /usr/share/applications/gnome-terminal.desktop can have something added in Exec= line.

  • I am sorry to have to downvote this, but it really amounts to mere speculation. If you can point to something specific in the env output I have pasted at dpaste.com/1A27524 I will be happy to remove the downvote. Thanks in advance. – tripleee Nov 27 '15 at 10:43
  • That quite hurts. Anyway, I added one other possibility to the answer. PS. The bug doesn't reproduce on my system so I couldn't look at env's output. In yours I don't see anything. – Sdaskr Nov 27 '15 at 10:47
  • The .desktop file is unremarkable, (Exec=gnome-terminal, no options) and would not affect the command-line invocation anyway. – tripleee Nov 27 '15 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.