I read a lot about the issues here with mysql server and client 5.6 on ubuntu 14.04 and tried all the things but I cannot get it to work.

Following steps I already took

sudo apt-get update
sudo apt-get remove --purge mysql-server mysql-client mysql-common
sudo apt-get autoremove
sudo apt-get autoclean
sudo rm -rf /var/lib/mysql
sudo rm -rf /etc/mysql
sudo apt-get install mysql-server-5.6

error from installation

Setting up mysql-common (5.6.25-3+deb.sury.org~trusty+1) ...
update-alternatives: error: alternative path /etc/mysql/my.cnf.fallback doesn't
dpkg: error processing package mysql-common (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can anyone help here? thanks a lot

  • Your problem is very similar to the one mentioned in the thread - askubuntu.com/questions/643251/… You might want to try the solution listed in it. – navjotjsingh Nov 27 '15 at 14:22
  • yep I already tried this, but this does not work for me either. I found another discussion where it was mentioned that a VM needs more RAM, I also increased it to 2048 but without success nvm I'm now bootstrapped a container with debian then :/ – xhallix Nov 27 '15 at 14:43
  • Any solution in above case ??? I am also stuck with the same – Er.KT Mar 8 '16 at 9:38
  • I found that the mysql was present but completely empty and it was not just the my.cnf.fallabck file that was missing – northern-bradley Jun 28 '16 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.