2

I am new to the ubuntu.my touchpad worked normally when i installed the ubuntu.But after while it stopped working abruptly.I can also able to external mouse.

here is my xinput list

 Virtual core pointer                       id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=9    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ TOSHIBA Web Camera                        id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]

My kernal is

Linux nithya-Satellite-C850 4.2.0-18-generic #22~14.04.1-Ubuntu SMP Fri >Nov 6 22:20:11 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

so please help to make the touchpad working.

  • What is the laptop model? What is the kernel version uname -a. Please edit your question and add this information TO YOUR QUESTION. – Pilot6 Nov 27 '15 at 8:56
  • You added only kernel version? What is your laptop model? – Pilot6 Nov 27 '15 at 9:21
  • toshiba-satellite-c850 – User5 Nov 27 '15 at 9:23
2

Most likely support of your touchpad has been added to new linux kernels. You can update the kernel by running in terminal:

sudo apt-get install linux-generic-lts-wily

Then reboot and try the touchpad.

  • still not working .now my kernel version shows as Linux nithya-Satellite-C850 4.2.0-18-generic #22~14.04.1-Ubuntu SMP Fri Nov 6 22:20:11 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux @Pilot6 – User5 Nov 27 '15 at 10:29
  • The touchpad is probably not supported yet. – Pilot6 Nov 27 '15 at 10:52
  • can you give any other suggestions? – User5 Nov 28 '15 at 8:21
  • In this case I would report a bug, or program a kernel fix. There is no easy solution I am afraid. – Pilot6 Nov 28 '15 at 8:28
  • now my touchpad works – User5 Nov 29 '15 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.