1

I've seen this question already asked and tried suggested solutions but none of them seem to work. I've had the wifi become disabled previously but rebooting the system usually worked. This is not working now. When I run rfkill list all, I get this:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

How do I undo the hard block? I'm using a Dell Inspiron N7010 with an Intel Centrino N-6200 card.

Edit: Output of lspci -knn | grep Net -A2 is as follows:

Inspiron-N7010:~$ lspci -knn | grep Net -A2 03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6200 [8086:422c] (rev 35) Subsystem: Intel Corporation Centrino Advanced-N 6200 2x2 AGN [8086:1301] Kernel driver in use: iwlwifi

  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Nov 26 '15 at 18:52
  • 1
    Hard blocked means that you have a hardware switch or button somewhere and this is switched to the off position. Sometimes, this is a fn button and other times there is an actual switch somewhere. – mchid Nov 27 '15 at 2:51
  • What options are in BIOS under Advanced/Wireless? – Jeremy31 Nov 27 '15 at 23:06
3

"Hard blocked" refers to a hardware switch not a software issue.

There should be a slider switch on either side of your laptop to enable wireless.

Here is an example of a similar one.

click to show if not displayed

In this photo, the wireless switch is on the left.

If you don't believe me, run the following command:

rfkill block 0

Now, check out what rfkill says:

rfkill list

and you should see now that you have a soft block in place:

0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

Run the following command to remove the Soft block:

rfkill unblock 0
  • 1
    There are also keyboard combinations on some laptops. You generally look on the function keys (F1, F2, etc.) for a WiFi symbol. Then you either just press that function key or you press, for example, Fn+F2 if F2 has the WiFi symbol on it. – Olathe Nov 27 '15 at 5:04
  • @Olathe I did think of this however, most Dell laptops have an actual switch and additionally, using an fn key combo to disable wifi will usually result in Soft blocked as well. – mchid Nov 27 '15 at 5:07
  • @Olathe I believe the fn combo for this computer is fn + F2 – mchid Nov 27 '15 at 5:08
  • 1
    I was just adding it because I think the answers for this question should be useful for most people running Ubuntu, rather than just for a specific Dell model. – Olathe Nov 27 '15 at 5:10
1

I'm having the same issue when resuming from suspend.

I wrote a script on sleep.d folder with

rfkill unblock all

this activates my wireless (all the rf devices) every time I resume my laptop.

This command may work for you too.

  • hard blocked usually refers to hardware switch instead of software. – mchid Nov 27 '15 at 2:50
  • @mchid I know, but worked for me. May sound weird but i'm thinking more on a software issue that makes the "Hard Block" status. – Николаи Милош Nov 27 '15 at 4:23
  • That usually falls under Soft blocked – mchid Nov 27 '15 at 4:49
  • @mchid I understand what you say, but maybe a software issue can cause to appear as "hard blocked" without being physically switched off. – Николаи Милош Nov 27 '15 at 19:35
0

I tried fn + f2 but that didn't work. What ultimately worked was shutting down the computer, removing the battery, holding the power button for 30 seconds, turning the computer back on and then going into the BIOS and resetting BIOS to the original settings. Not sure why it worked but after the computer powered up, wifi was active again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.