Until recently both my Windows Partition (C:) and my Data Partition (E:) would mount as read/write. Now both seem to only mount as read-only.

GParted Resize (Error)

ntfsresize v2.0.0 (libntfs 10:0:0)
Device name : /dev/sda4
NTFS volume version: 3.1
Cluster size : 4096 bytes
Current volume size: 86207623680 bytes (86208 MB)
Current device size: 86207627264 bytes (86208 MB)
New volume size : 78662066688 bytes (78663 MB)
Checking filesystem consistency ...
Accounting clusters ...
Space in use : 62126 MB (72.1%)
Collecting resizing constraints ...
Needed relocations : 1606868 (6582 MB)
Schedule chkdsk for NTFS consistency check at Windows boot time ...
Resetting $LogFile ... (this might take a while)
Relocating needed data ...
ERROR: Extended record needed (1032 > 1024), not yet supported!
Please try to free less space.

chkdsk Output:

Checking file system on E:
The type of the file system is NTFS.
Volume label is Data.

A disk check has been scheduled.
Windows will now check the disk.                         
  99482 file records processed.
  495 large file records processed.                     
  0 bad file records processed.                         
  0 EA records processed.                               
  0 reparse records processed.                          
  104412 index entries processed.                       
  0 unindexed files processed.                          
  99482 security descriptors processed.                 
  2466 data files processed.                            

CHKDSK is verifying Usn Journal...
  4479208 USN bytes processed.                                     
Usn Journal verification completed.
Windows has checked the file system and found no problems.

84187132 KB total disk space.
  60479688 KB in 69969 files.
     15520 KB in 2467 indexes.
         0 KB in bad sectors.
    174336 KB in use by the system.
     65536 KB occupied by the log file.
  23517588 KB available on disk.
      4096 bytes in each allocation unit.
  21046783 total allocation units on disk.
   5879397 allocation units available on disk.

Internal Info:
9a 84 01 00 00 1b 01 00 fc 1a 01 00 00 00 00 00  ................
01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
42 00 00 00 52 73 5c 77 b0 e7 1d 00 b0 df 1d 00  B...Rs\w........


# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=8213cc89-2438-41b9-899f-13b4c5b299af /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=45873767-d9ae-4f0c-baab-ffc2726ac24e none            swap    sw              0       0

Checked the drive in GParted, GSmartControl and with ntfsfix, all completed successfully, no change.


dev/sda1 NTFS WinRE
dev/sda2 NTFS Windows C:
dev/sda3 Extended
dev/sda4 NTFS Data E:
dev/sda5 EXT4 Ubuntu
dev/sda6 linux-swap

I am looking for an explanation of:

Internal Info:
9a 84 01 00 00 1b 01 00 fc 1a 01 00 00 00 00 00  ................
01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
42 00 00 00 52 73 5c 77 b0 e7 1d 00 b0 df 1d 00  B...Rs\w........


Resetting $LogFile ... (this might take a while)
Relocating needed data ...
ERROR: Extended record needed (1032 > 1024), not yet supported!
Please try to free less space.
  • Can you write data to the partition? If not then read my answer below. And are you trying to resize, and not able to, thus the assumption its read-only? or are you actually trying to write data to the drive? – Thomas Ward Oct 21 '11 at 16:36

The system might not have the files for writing to NTFS partitions installed.

Try this in terminal:

sudo apt-get remove ntfsprogs && sudo apt-get install ntfs-3g

This removes ntfsprogs if it's present on the system, and installs ntfs-3g which should allow you to write properly to NTFS partitions.

Then reboot your system, and attempt to open the NTFS drive for write access. You should now be able to write to the NTFS drive.

  • Running that command results in the system prompting me to remove ntfsprogs, which i looked up, and doesn't seem to list anything about writing to ntfs generally, so i removed it. This seems to have fixed it, i think i installed ntfsprogs when looking to run a disk check under ubuntu due to bad sectors (10 of them). Thanks! – Lewis Goddard Oct 21 '11 at 16:39
  • Yep. Your question was a bit misleading though, because of the data you attached. That data that is attached generally doesn't explain why you can't write to the drive - rather we see that you're trying to resize the drive in that data. – Thomas Ward Oct 21 '11 at 18:14
  • 1
    Removing the ntfsprogs when installing ntfs-3g solved the read only problem. – Luis Alvarado Dec 13 '11 at 3:25
  • Got NTFS file creation working for me, cheers. – Gerry Jul 24 '12 at 15:56

Performing a full shutdown of Windows will allow the drives to be fully mounted by Ubuntu. This can be accomplished by holding the SHIFT key as you press the "Shut down" button on the "Power" menu.

  • 4
    Can this be done if the Windows partition is gone? Put another way, can I do this if Windows is no longer installed? – epotter Oct 30 '17 at 23:58
  • No, this trick is only useful if you have Windows installed as there is no "Shut down" button to click if you don't have Windows installed. – schulwitz Oct 31 '17 at 0:55
  • 1
    thanks, this worked for me... my windows 10 partition was read only before but after following instructions from the page , its not.... – waqar Mar 25 '18 at 5:05
  • 14
    To avoid having to hold-down Shift every time you shutdown Windows (it's easy to forget in a dual-boot configuration), you can simply disable Hibernation entirely, which also disables Hybrid Boot, thereby making this a non-issue. When booted into Windows, launch an elevated Command Prompt ("Run as Administrator") and type powercfg /h off and hit Enter. Then, reboot into Ubuntu, and the NTFS drive will be writable. If you'd prefer not to disable Hibernation entirely, you can disable only Hybrid Boot using Control Panel (I couldn't find a command-line method); see link in the Answer for guide. – Ben Johnson Jul 19 '18 at 0:44
  • Worked for my Windows 10+Ubuntu 18.04 dual boot. Thanks! – Negrito Apr 22 '19 at 13:30

Happened to me, all I did was

sudo ntfsfix /dev/sdxX # where x is HDD and X is drive number, in my case it was /dev/sda1

it will remove any logfile created by windows.

worked for me.

  • 1
    This feels dangerous. While it does make the disk writeable again by removing Windows cache files in Linux, what happens when you boot into Windows again? – Paul May 6 '19 at 22:11
  • thank you very much I have a 2nd hdd that I used once in windows and could not mount in read/write anymore under ubuntu this fixed it – wraith3690 001 Sep 27 '19 at 20:47
  • 3
    I had to umount and mount again after run ntfsfix – deFreitas Dec 25 '19 at 12:53
  • 1
    @Paul my Windows 10 booted ok after this – Klesun Jan 18 '20 at 16:23
  • 3
    thanks, as deFreitas stated after amount/mount works a treat. no reboots needed. thanks so much – Nik Burns Jan 28 '20 at 16:09

If it happens in case of dual booting with Windows 10, you need to uncheck turn on fast startup in Control Panel --> Power Options --> Choose what the power buttons do and then shutdown, not reboot. Once it's done properly you'll be able to access the NTFS partitions normally with read/write permissions.

This happens due to the Windows 10 update resets it to the default fast startup which is a form of hibernation.

enter image description here

  • 1
    +1 This solved my problem. – lanenok Apr 27 '20 at 14:16
  • 2
    This is cleaner, no fixes, just deactivate a config. good job. – mancvso Feb 21 at 15:49

try below solution only if last resort only

I tried all solution. none of them work. this may be due to windows disk error(bad sector) & wasn't shutdown properly.

Only work solution me for delete everything from nvme drive.Note that this will remove everything on storage/nvme drive.

apt-get install nvme-cli

To delete everything or format drive I used tool called "nvme-format" http://manpages.ubuntu.com/manpages/cosmic/man1/nvme-format.1.html

 nvme format /dev/nvmeXY # where nvmeXY is device name

note: this will erase everything from drive.

  • 1
    Happened to me as well after the laptop battery died while on Windows. Rebooting to Windows and boot back to Linux fixed issue. – krim Nov 14 '20 at 2:54
  • True. this(restart to windows & properly shutdown) solution was given by @schulwitz above – Kaushal Nov 17 '20 at 6:52

Follow these steps:

  1. Open terminal and type:

    $ blkid
  2. Find the partition (if you have a single HDD then it will be /dev/sdax and another HDD will be sdbx).

  3. Run the following command, where a is the HDD's position and 5 is the partition's position:

    $ sudo ntfsfix /dev/sda5

It's worked for me!


Sometimes the feature "Disable Fastboot" is prohibited to change by non-admin user by group policy restriction.

The below solution will help for all situations.

Login to windows, close all opened windows if any and execute following, from Run dialog

shutdown /f /r /t 0

/f Force running applications to close without forewarning users.

/r Full shutdown and restart the computer.

/t xxx Set the time-out period before shutdown to xxx seconds.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.