3

I have a problem with my usb wireless stick (TP-LINK TL-WN821N) when I'm surfing on the net or something like that, so in every ~30 minutes I get disconnected from the internet, unfortunatly whent it happens I always have to unplug and then connect this usb device so that I can connect to the internet again.

ps: under windows it works properly and under the previous version of ubuntu

2

I suggest you to do the trick proposed in the comment 13 of this Launchpad bug, that is to blacklist the ar9170usb driver:

https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.32/+bug/495562

  • yes i did the same ..blacklist the driver and it worked properly – One Zero Jan 25 '12 at 15:35
1

This seems to be a driver bug. See the official documentation for that card:

And the bug reports in launchpad:

Some fixes / workarounds are described. Disabling the N-thingy seemed to work accoding to this answer:

0

Ok i "solved" the problem by manually configuring wireless! HOW TO: 1) Make a config file like this:

ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="Your_neworkName"
        psk="Password"
        key_mgmt=WPA-PSK
        proto=WPA2
        pairwise=CCMP TKIP
        group=CCMP TKIP
}

see this for more details how to. And save it to /etc/wpa_supplicant/wpa_conf.conf 2) Disable your network manager:

sudo /etc/init.d/NetworkManager stop

then test your configuration by running:

sudo wpa_supplicant -D wext -i wlan0 -c /etc/wpa_supplicant/wpa_conf.conf

Is everything working? Nice go ahead to step 3)

3) Make a new script on your desktop called connect.sh containing

/etc/init.d/NetworkManager stop
ifconfig wlan0 down
dhclient -r wlan0
wpa_supplicant -D wext -i wlan0 -c /etc/wpa_supplicant/wpa_conf.conf
dhclient wlan0

and assure it is runnable.

4) Install "alacarte" (if Ubuntu 11.10) and create a new Launcher in Network Menu:

  • Name: Connnect
  • Command: gksudo /path/to/your/script.sh
  • Description and icon: everything you like.

5)Search for "Connect" on your Dash and drag and drop it to your Dock ;)

6)Everytime you need to connect to your network just launch "Connect app" and it's done.

N.B. You need to configure every wireless network by hand!!! Please contact me if something doesn't work!

0

I had exactly the same problem with my stick (TP-LINK TL-WN821N V3). After downloading latest network drivers by following this blog entry, it works a lot better:

http://whilesurfing.blogspot.com/2012/02/ubuntu-tp-link-tl821nv3-tl822n-v20.html

0

The below link is an correct solution for TL-WN823N / WN821N Driver https://github.com/pvaret/rtl8192cu-fixes/blob/master/README.md

  • 1
    Hello Abu, welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. That way, in case your link goes down, the answer will still be available through Ask Ubuntu ;-). – hg8 Dec 23 '15 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.