1

I have installed Ubuntu along Windows 10, but when I restart my computer it boots directly into windows 10.

I tried using boot-repair including command line instructions for Windows 10 and still no solution. Ubuntu is installed in EFI mode.

I have tried everything I can think of to get the option to boot into Ubuntu on restart (a lot of googling and still nothing).

I can get into Ubuntu if I restart windows holding shift and choose troubleshoot and then choose UEFI settings and restart into those settings choose boot device and then select Ubuntu rather than Windows 10 but would like to boot into Ubuntu without doing this.

Please help.

  • Which version of Ubuntu? eg. 14.04 LTS or 15.10 – david6 Nov 26 '15 at 7:41
  • 1
    Take a look at this question. – adeen-s Nov 26 '15 at 8:41
0

Go to

/etc/default/grub

file and find this line :

GRUB_HIDDEN_TIMEOUT=0

and put # symbol at the start of the line. So that it looks like

#GRUB_HIDDEN_TIMEOUT=0

Then save the settings (ctrl+s)

and run this command

sudo update-grub

to apply the changes

  • Thank you SuDo User but that line was already commented out. Also it is Ubuntu 14.04 – Megan Nov 27 '15 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.