1

I'm trying to build the package but I'm getting this dependency missing message:

NOTE: If your system has logged the missing packages required for installation, install them in the order as per the log file to resolve package-dependency issues.
Check if system has the tools required for Packages Generation.
To build kernel modules of AMD, system needs Kernel-Development package to be installed
Please run command: sudo zypper install kernel-devel <we presume, you have DVD in the CD driver>

One or more tools required for Graphics Pacakges Generation are not found on the system. Recommended is to install the required tools for successful package generation.
Optionally, you can run commands to ignore these dependecies but end result may not be as expected. Not recommended

I already installed the headers for 4.2.0-18-generic kernel, and solved the "version.h" missing according to this post. But can't proceed with building the ATI driver...

Can someone help, please !?

2

I had the same problem and solved it by following the instructions from this page. The page is written in spanish, but all the commands are in english, so it's pretty straightforward.

According with this page, there is a bug in the Ubuntu/wily AMD installation script. That's why you can't install the new driver.

Just to warn you, the command

sudo ./amd-driver-installer-15.30.1025-x86.x86_64.run --buildpkg Ubuntu/wily

may take some minutes to finish, so don't think that the terminal is frozen.

And there's also a little mistake in the command

sudo dpgk -i *.deb

The correct command is

sudo dpkg -i *.deb

Hope that it helps!

  • There is also a bug (I am not surprised, shame on you, AMD!) in build script, so the debs would be located in /tmp. But the answer is correct – Grief Dec 7 '15 at 20:35
  • I had a lot of troubles after installing the new fglrx driver. So, I go back to opensource radeon driver for now... – Victoralm Dec 9 '15 at 2:41
0

It looks like you are trying to build the package with the GUI.

The GUI checks for dependencies using a file list rather than dpkg. This is a bad method, and breaks with certain kernel updates. The solution is to simply run the build package from the command prompt.

sudo ./amd-driver-installer-15.30.1025-x86.x86_64.run --buildpkg Ubuntu/wily

Furthermore, as mentioned above by someone else, you shouldn't rely on the tools to install the package for you, as again the scripts are problematic at best.

Just use "dpkg -i ./fglrx*.deb" instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.