0

I got an error during installation of wpa_supplicant in Ubuntu 14.04.

enter image description here

Please help me to solve this error.

  • I figure it out. Problem is I miss the ncurses library. It is a programming library providing an API that allows the programmer to write text-based user interfaces in a terminal-independent manner. just install all the newest ncurses library packages: "sudo apt-get install libncurses*" This works for me. – Janaka Pushpakumara Nov 25 '15 at 8:33
  • 1
    Possible duplicate of How to install software provided in software-center via terminal? – the package name is wpasupplicant. – David Foerster Feb 14 '16 at 9:00
1

You have to install the development libraries:

sudo apt-get install libncurses5-dev

and please don't use sudo apt-get install libncurses* or do you need all this packages?

libncurses5 - shared libraries for terminal handling
libncurses5-dbg - debugging/profiling libraries for ncurses
libncurses5-dev - developer's libraries for ncurses
libncursesw5 - shared libraries for terminal handling (wide character support)
libncursesw5-dbg - debugging/profiling libraries for ncursesw
libncursesw5-dev - developer's libraries for ncursesw
libncurses-gst - Ncurses bindings for GNU Smalltalk
libncursesada-dbg - Ada binding to the ncurses text interface library: debug symbols
libncursesada-doc - Ada binding to the ncurses text interface library: documentation
libncursesada3 - Ada binding to the ncurses text interface library: shared library
libncursesada3-dev - Ada binding to the ncurses text interface library: development

Probably not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.