I have the low battery alarm disabled in the BIOS settings on my Lemur laptop, but the alarm still sounds when the battery is low. The sound is a very loud and annoying beep that repeats every couple seconds. The laptop will last another 20 minutes without being plugged in so the battery level isn't properly being detected anymore anyways. I found that if I mute my audio then the beep stops but I obviously cannot listen to anything anymore. If i turn the volume back on even to just 1% the battery alarm is audible again at full volume. I remember there used to be a mixer somewhere that could control the internal speaker and so if I could find that again then maybe i could mute that and fix this problem.

I have Ubuntu 14.04. Note that I'm not talking about a low battery notification, which is something through gnome; as opposed to a low battery ALARM which is this very loud beep every couple seconds coming through the internal speaker. Nevertheless, here are my gnome power settings:

$ gsettings list-recursively org.gnome.settings-daemon.plugins.power
org.gnome.settings-daemon.plugins.power button-power 'interactive'
org.gnome.settings-daemon.plugins.power critical-battery-action 'nothing'
org.gnome.settings-daemon.plugins.power percentage-low 1
org.gnome.settings-daemon.plugins.power priority 0
org.gnome.settings-daemon.plugins.power lid-close-suspend-with-external-monitor false
org.gnome.settings-daemon.plugins.power idle-dim false
org.gnome.settings-daemon.plugins.power button-hibernate 'hibernate'
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'suspend'
org.gnome.settings-daemon.plugins.power button-sleep 'suspend'
org.gnome.settings-daemon.plugins.power button-suspend 'suspend'
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 0
org.gnome.settings-daemon.plugins.power time-low 1200
org.gnome.settings-daemon.plugins.power lid-close-ac-action 'nothing'
org.gnome.settings-daemon.plugins.power notify-perhaps-recall true
org.gnome.settings-daemon.plugins.power percentage-critical 1
org.gnome.settings-daemon.plugins.power percentage-action 1
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'
org.gnome.settings-daemon.plugins.power time-action 120
org.gnome.settings-daemon.plugins.power lid-close-battery-action 'nothing'
org.gnome.settings-daemon.plugins.power idle-brightness 30
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0
org.gnome.settings-daemon.plugins.power time-critical 300
org.gnome.settings-daemon.plugins.power active true
org.gnome.settings-daemon.plugins.power use-time-for-policy false

1 Answer 1


If you have already disabled the setting in BIOS and the deactivation of the modules does not help, as described below, then you probably have a bug in the BIOS.

Disable the internal speaker:

sudo modprobe -r pcspkr snd_pcsp

For a permanent solution, edit /etc/modprobe.d/blacklist.conf

sudo nano /etc/modprobe.d/blacklist.conf

and add/change

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr
  • i already have blacklist snd_pcsp and blacklist pcspkr in /etc/modprobe.d/blacklist.conf
    – scar
    Nov 26, 2015 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.