1

This question already has an answer here:

> proxychains skype
> ProxyChains-3.1 (http://proxychains.sf.net)
> ERROR: ld.so: object 'libproxychains.so.3' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

I am using proxychains on Ubuntu 15.10 an have googled this issue many times and cannot find it. The problem is that skype is a 32bit application and proxychains is installed as a 64bit, so it isn't able to work with skype. I have googled this issue and found no legitimate solutions.

EDIT: not only does it not work for skype, but there are other applications as well that I have that are 32bit that it doesn't work with.

I also tried googling how to run a 32bit program on Ubuntu 15.10. To be clear, I do not just need to run it, it has to be ran as a 32bit and the libraries need to be downloaded as 32bit. Since i am on 64bit and proxychains is 64bit it already runs, just not with skype. Does anyone know I can fix this and get it working without the LD_PRELOAD error?

marked as duplicate by A.B., Pilot6, Ravan, Charles Green, Eric Carvalho Nov 26 '15 at 13:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • No. The app already runs, i need to use install it as a 32bit. NOt run it. It runs perfectly fine, just not with skype or other 32bit applications ;/ – Jason Rigley Nov 25 '15 at 4:53
  • You need to install and run the 32-bit version of proxychains. This cannot be done typically through the package manager, if you still want to retain the 64-bit version. You'll need to find a way to install both at the same time (including architecture-specific dependencies) and then set up things, so you can use something like proxychain32 skype. – David Foerster Nov 26 '15 at 12:20
1

Install the 32-bit package of libproxychains3

sudo apt-get install libproxychains3:i386

and read Why are there so many 32-bit dependencies for Skype?.

  • |DNS-response|: pipe.skype.com does not exist /usr/lib/proxychains3/proxyresolv: 16: /usr/lib/proxychains3/proxyresolv: dig: not found are any of those errors things I should be concerned about? Skype starts up without my origional error, but i keep getting those throughout while it is running – Jason Rigley Nov 25 '15 at 18:57
  • Seems to be a different problem. Perhaps you should ask a new question. – A.B. Nov 25 '15 at 18:58
  • Your comment worked for proxychains 3, but I recently installed proxychains 4 from rofl0r's github page (because it was much upgraded) and now I am getting the error: ERROR: ld.so: object '/usr/local/lib/libproxychains4.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored. I tried installing libproxychains4:i386 but the package doesn't exist ... any idea how i can fix this? – Jason Rigley Nov 26 '15 at 19:16
  • The package is also not available for 16.04. You have to compile it. – A.B. Nov 26 '15 at 19:46
  • Seems to be a bigger problem. Please ask a new question and give me the link. – A.B. Nov 26 '15 at 19:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.