After fresh install of oneiric 11.10 nothing displayed during boot process, but I still can switch to tty's. I made apt-get update/upgrade from tty and tried to reboot. Nothing changed. 'service lightdm restart' and 'startx' also doesn't help.

UPD(24.10.2011): Just reported bug with apport-bug to launchpad. You can see there logs and others collected reports.

  • nVidia Corporation C51G[GeForce 6100](rev a2) also during startx there is an error string: Failed to load module "nv" (module does not exists, 0) – Guria Oct 24 '11 at 8:59
  • No changes. Just 'nomodeset' caused ubuntu-logo with dots looks textual instead of graphical and less resolution for tty's. But it didn't help boot to DM. 'nomodeset xforcevesa' also doesn't led to desired. The same behavior. – Guria Oct 25 '11 at 10:44

Try sudo apt-get purge nvidia replace nvidia by the driver you are using. It will use the free driver Nouveau.

That worked for me.

| improve this answer | |
  • Thanks a lot. "sudo apt-get purge nvidia-173" was helpfull for me. Also I have to select Unity 2d in lightdm. – Guria Oct 25 '11 at 11:30
  • Will award you bounty tomorrow. – Guria Oct 25 '11 at 11:31
  • sudo apt-get purge nvidia-173 worked for me also. Seems that the new 3.0 Linux kernel doesn't has the "nv" module... It's very messy having to fix that by hand. Also after booting the desktop, the visuals were a bit slow and after a while, the system hanged. Having been using Ubuntu for a while, I'm very dissappointed with Oneiric Ocelot. :( – Alejandro García Iglesias Oct 26 '11 at 16:35

Try this:

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
| improve this answer | |
  • No changes. Also tried 'sudo apt-get install --reinstall nvidia-173' – Guria Oct 24 '11 at 11:12
  • try sudo apt-get install nvidia-current since you are using a nvidia card, this will install the latest driver package for your system. – Bruno Pereira Oct 24 '11 at 11:46
  • No changes. Package was not on my system, but installing it has not resolved an issue. PS. my VGA is integrated on motherboard. – Guria Oct 24 '11 at 12:51
  • Yeah, i have checked it, dont think your card is not supported anymore, just not sure its 100% supported. This is so weird :S the 'nv' module fault is the only thing you see faulty during boot? – Bruno Pereira Oct 24 '11 at 13:00
  • All logs are available in launchpad bug. See UPD – Guria Oct 24 '11 at 15:02

another way to restart the window manager should be

sudo initctl restart lightdm
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.