1

I hope this is not too much of a duplicate, I tried checking out old questions and answers but without luck, UEFI has been giving problems for 3+ years now but still I struggle with it.

Here's the situation: I have an ACER Aspire VN7, I am trying to install Ubuntu 15.10 on it with dual boot (leaving the original windows 10 aside). But I can't succeed making the pc see the Ubuntu USB stick, no matter what.

As advised, I disabled Windows quick startup from the control panel, disabled the security lock in the BIOS (but there doesn't seem to be any quick startup option to disable there), but still the machine will ignore the bootable USB stick altogether.

I also tried Rod Smith's rEFInd alongside, as he suggested on some old answer. The result is that my pc boots on rEFInd as it should but still ignores the Ubuntu USB (not even within rEFInd does it show up as an option).

I managed to successfully boot from the same Ubuntu 15.10 USB stick after switching the BIOS boot to Legacy instead of UEFI, but UEFI has been standard for Windows for at least 3 years now and I would definitely prefer if a UEFI solution could be found.

I will be very grateful to anybody who could provide advices or insights!

  • Did you put the USB first in the boot order? Did you try to use the EFI boot menu to select a boot device? – ubfan1 Nov 23 '15 at 23:29
  • I have changed the order in the BIOS putting USB first (that's how I got rEFInd to launch in the first place). It's just Ubuntu stick that won't get recognized... – Marco Spinaci Nov 24 '15 at 17:03
1

How did you prepare the USB drive? Some programs for writing .iso files to USB flash drives omit EFI boot loaders and so won't work for booting in EFI mode. Some have options that affect bootability. Some create USB flash drives that work OK on some EFI-based computers but not on others. In short, you may need to try another program. I have notes on several programs here. In brief, Rufus under Windows seems pretty flexible and reliable. From Ubuntu, I generally use dd, but some people like UNetbootin. Even if you use a program that's generally reliable, though, it might be failing for your computer, so you may need to try something else.

If you are forced to do a BIOS/CSM/legacy-mode install, I recommend doing it as follows:

  1. Launch the installer in its "try before installing" mode.
  2. Open a Terminal window.
  3. Type ubiquity -b. This launches the installer and tells it to not install a boot loader.
  4. When the installation has finished, boot with the rEFInd USB flash drive you already have. It should detect your Ubuntu installation and enable you to boot it.
  5. Install the EFI-mode version of GRUB (in the grub-efi package), rEFInd, or any other boot loader you like to the computer's hard disk. This should enable you to boot without the rEFInd USB drive.

Upon re-reading your answer, it's unclear if you used rEFInd on a USB drive or installed it from Windows. If the latter, you may need to install an EFI filesystem driver for your Ubuntu filesystem (ext4fs by default), but if you're happy with rEFInd, you won't need to re-install it.

  • Thanks a lot for your insightful answer! I tried startup disk creator, dd, the copy-and-paste method proposed in askubuntu.com/questions/372607/… (all these with the same ubuntu 15.10 iso) and lastly by downloading unetbootin and letting it download a version of 14.04 (you never know, maybe the iso was corrupted), on two different usb sticks. Still no chance, on any of the two USB sticks rEFInd works flawlessly but neither it nor the BIOS detects the Ubuntu usb stick at all. I fear I'll have to cope with Legacy mode :-( – Marco Spinaci Nov 24 '15 at 16:33
  • Regarding the "re-reading" part: I put rEFInd on a USB stick and, at the same time, Ubuntu on another. In this configuration, the computer automatically boots on rEFInd, which doesn't see Ubuntu. Actually, if two sticks are bootable, I don't know how to tell the BIOS which one to choose, hence I also tried to remove rEFInd stick and leave only Ubuntu stick on, in which case it just ignores it and proceeds to Windows... I haven't tried to install rEFInd directly on the machine, it is cool and I will probably do that if everything works fine, but I have no more ideas about what to try... – Marco Spinaci Nov 24 '15 at 16:40
  • Please check your bit depth. The rEFInd "About" screen shows the bit depth of rEFInd (and therefore of your EFI) on the "Platform" line. Be sure that matches the bit depth of your Ubuntu. – Rod Smith Nov 24 '15 at 18:38
  • About tells me that EFI Revision is 2.40 and that the platform is x86_64 (64 bit). I made sure to download ubuntu-15.10-desktop-amd64.iso and to ask UNetbootin to download 14.04 Live x64, so I guess that it matched in both cases? (the rest of the info it gives me are: Secure Boot inactive, Firmware INSYDE Corp. 21799.25, and screen info) – Marco Spinaci Nov 24 '15 at 22:02
  • That sounds right. You might want to look for the boot loader file with a file manager. It should be EFI/BOOT/bootx64.efi on the removable disk. If no such file is present, then the disk was created incorrectly. One more thing: In rEFInd, hit Esc to re-scan your disks. That sometimes causes boot loaders to appear that don't show up immediately. – Rod Smith Nov 24 '15 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.