0

No matter the program, I get an Error: The file "home/..." could not be opened.

I was able to install VMware using gksudo bash command; however it does not work with any other programs.

I have also tried sudo apt-get install

Output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libqt4-webkit:i386 python-commandnotfound python-gdbm
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 4 not upgraded.
Need to get 325 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ca.archive.ubuntu.com/ubuntu/ trusty-updates/main software-center all 13.10-0ubuntu4.1 [325 kB]
Fetched 325 kB in 6s (49.6 kB/s)                                               
(Reading database ... 203377 files and directories currently installed.)
Preparing to unpack .../software-center_13.10-0ubuntu4.1_all.deb ...
Unpacking software-center (13.10-0ubuntu4.1) over (13.10-0ubuntu4.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up software-center (13.10-0ubuntu4.1) ...
Updating software catalog...this may take a moment.
INFO:softwarecenter.db.pkginfo_impl.aptcache:aptcache.open()
Software catalog update was successful.
jakezeal@jakezeal-P35V3:~$ sudo apt-get update
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://security.ubuntu.com trusty-security InRelease                       
Ign http://ca.archive.ubuntu.com trusty InRelease                    
Ign http://extras.ubuntu.com trusty InRelease                        
Hit http://ppa.launchpad.net trusty Release.gpg                                
Hit http://extras.ubuntu.com trusty Release.gpg                                
Get:1 http://ca.archive.ubuntu.com trusty-updates InRelease [64.4 kB]
Hit http://security.ubuntu.com trusty-security/main Sources                    
Hit http://extras.ubuntu.com trusty Release                                    
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://security.ubuntu.com trusty-security/restricted Sources              
Hit http://extras.ubuntu.com trusty/main Sources                               
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://security.ubuntu.com trusty-security/universe Sources                
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://extras.ubuntu.com trusty/main amd64 Packages                        
Hit http://security.ubuntu.com trusty-security/multiverse Sources              
Hit http://extras.ubuntu.com trusty/main i386 Packages                         
Hit http://security.ubuntu.com trusty-security/main amd64 Packages             
Hit http://ca.archive.ubuntu.com trusty-backports InRelease                    
Hit http://security.ubuntu.com trusty-security/restricted amd64 Packages       
Hit http://ca.archive.ubuntu.com trusty Release.gpg                            
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages         
Get:2 http://ca.archive.ubuntu.com trusty-updates/main Sources [245 kB]        
Hit http://security.ubuntu.com trusty-security/multiverse amd64 Packages       
Hit http://security.ubuntu.com trusty-security/main i386 Packages              
Hit http://security.ubuntu.com trusty-security/restricted i386 Packages        
Hit http://security.ubuntu.com trusty-security/universe i386 Packages          
Hit http://security.ubuntu.com trusty-security/multiverse i386 Packages        
Ign http://ppa.launchpad.net trusty/main Translation-en_CA                     
Hit http://security.ubuntu.com trusty-security/main Translation-en             
Ign http://extras.ubuntu.com trusty/main Translation-en_CA                     
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en       
Get:3 http://ca.archive.ubuntu.com trusty-updates/restricted Sources [5,359 B] 
Ign http://extras.ubuntu.com trusty/main Translation-en                        
Hit http://security.ubuntu.com trusty-security/restricted Translation-en       
Get:4 http://ca.archive.ubuntu.com trusty-updates/universe Sources [143 kB]    
Hit http://security.ubuntu.com trusty-security/universe Translation-en         
Get:5 http://ca.archive.ubuntu.com trusty-updates/multiverse Sources [5,133 B] 
Get:6 http://ca.archive.ubuntu.com trusty-updates/main amd64 Packages [653 kB] 
Get:7 http://ca.archive.ubuntu.com trusty-updates/restricted amd64 Packages [15.9 kB]
Get:8 http://ca.archive.ubuntu.com trusty-updates/universe amd64 Packages [327 kB]
Get:9 http://ca.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [13.0 kB]
Get:10 http://ca.archive.ubuntu.com trusty-updates/main i386 Packages [631 kB] 
Get:11 http://ca.archive.ubuntu.com trusty-updates/restricted i386 Packages [15.6 kB]
Get:12 http://ca.archive.ubuntu.com trusty-updates/universe i386 Packages [328 kB]
Get:13 http://ca.archive.ubuntu.com trusty-updates/multiverse i386 Packages [13.1 kB]
Hit http://ca.archive.ubuntu.com trusty-updates/main Translation-en            
Hit http://ca.archive.ubuntu.com trusty-updates/multiverse Translation-en      
Hit http://ca.archive.ubuntu.com trusty-updates/restricted Translation-en      
Hit http://ca.archive.ubuntu.com trusty-updates/universe Translation-en        
Hit http://ca.archive.ubuntu.com trusty-backports/main Sources                 
Hit http://ca.archive.ubuntu.com trusty-backports/restricted Sources           
Hit http://ca.archive.ubuntu.com trusty-backports/universe Sources             
Hit http://ca.archive.ubuntu.com trusty-backports/multiverse Sources           
Hit http://ca.archive.ubuntu.com trusty-backports/main amd64 Packages          
Hit http://ca.archive.ubuntu.com trusty-backports/restricted amd64 Packages    
Hit http://ca.archive.ubuntu.com trusty-backports/universe amd64 Packages      
Hit http://ca.archive.ubuntu.com trusty-backports/multiverse amd64 Packages    
Hit http://ca.archive.ubuntu.com trusty-backports/main i386 Packages           
Hit http://ca.archive.ubuntu.com trusty-backports/restricted i386 Packages     
Hit http://ca.archive.ubuntu.com trusty-backports/universe i386 Packages       
Hit http://ca.archive.ubuntu.com trusty-backports/multiverse i386 Packages     
Hit http://ca.archive.ubuntu.com trusty-backports/main Translation-en          
Hit http://ca.archive.ubuntu.com trusty-backports/multiverse Translation-en    
Hit http://ca.archive.ubuntu.com trusty-backports/restricted Translation-en    
Hit http://ca.archive.ubuntu.com trusty-backports/universe Translation-en      
Hit http://ca.archive.ubuntu.com trusty Release                                
Hit http://ca.archive.ubuntu.com trusty/main Sources                           
Hit http://ca.archive.ubuntu.com trusty/restricted Sources                     
Hit http://ca.archive.ubuntu.com trusty/universe Sources                       
Hit http://ca.archive.ubuntu.com trusty/multiverse Sources                     
Hit http://ca.archive.ubuntu.com trusty/main amd64 Packages                    
Hit http://ca.archive.ubuntu.com trusty/restricted amd64 Packages              
Hit http://ca.archive.ubuntu.com trusty/universe amd64 Packages                
Hit http://ca.archive.ubuntu.com trusty/multiverse amd64 Packages              
Hit http://ca.archive.ubuntu.com trusty/main i386 Packages                     
Hit http://ca.archive.ubuntu.com trusty/restricted i386 Packages               
Hit http://ca.archive.ubuntu.com trusty/universe i386 Packages                 
Hit http://ca.archive.ubuntu.com trusty/multiverse i386 Packages               
Hit http://ca.archive.ubuntu.com trusty/main Translation-en_CA                 
Hit http://ca.archive.ubuntu.com trusty/main Translation-en                    
Hit http://ca.archive.ubuntu.com trusty/multiverse Translation-en              
Hit http://ca.archive.ubuntu.com trusty/restricted Translation-en              
Hit http://ca.archive.ubuntu.com trusty/universe Translation-en_CA             
Hit http://ca.archive.ubuntu.com trusty/universe Translation-en                
Ign http://ca.archive.ubuntu.com trusty/multiverse Translation-en_CA           
Ign http://ca.archive.ubuntu.com trusty/restricted Translation-en_CA           
Fetched 2,461 kB in 57s (42.6 kB/s)                                            
Reading package lists... Done

I am running the latest version of Ubuntu 14.04.3 LTS as the only OS on my SSD harddrive. Additionally, I have updated everything through sudo apt-get update

Additionally, I tried reinstalling the Software Center.

  • 1
    What is the exact error message? – Pilot6 Nov 23 '15 at 20:40
  • "Error: The file "home/..." could not be opened." – Jake Zeal Nov 23 '15 at 20:44
  • And nothing else? Or some file name is also there? – Pilot6 Nov 23 '15 at 20:44
  • Please give output of sudo apt-get update. Are there any errors? – Pilot6 Nov 23 '15 at 20:45
  • 1
    Please edit your question and add output there. And what do you try to do with the Software Center? Open the script with it or what? – Pilot6 Nov 23 '15 at 20:51
2

You can't run bash scripts by Ubuntu Software Center.

You can run this script in terminal by running:

sh /home/jakezeal/Anaconda2-2.4.0-Linux-x86_64.sh

or just

./Anaconda2-2.4.0-Linux-x86_64.sh

if your current directory is /home/jakezeal.

  • The output is: ` bash: ./Anaconda2-2.4.0--Linux-x86_64.sh: No such file or directory ` – Jake Zeal Nov 23 '15 at 21:02
  • Where is this file located? – Pilot6 Nov 23 '15 at 21:02
  • There was a spelling mistake. Wow so in the future, I simply type ./ before the file I would like to install ? – Jake Zeal Nov 23 '15 at 21:04
  • Correct if the file is in your Home directory. – Pilot6 Nov 23 '15 at 21:05
  • The file name was: ./Anaconda2-2.4.0-Linux-x86_64.sh (you added a dash) – Jake Zeal Nov 23 '15 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.