106

GNOME shell has the so-called feature "hot corner", that opens the dashboard if the mouse touches the top-left corner of a monitor screen.

I want this disabled I used to have a GNOME shell extension, yet the repository is not found anymore:

git clone [email protected]/Ahrak/gnome-shell-extension-disable-hot-corners.git
fatal: repository '[email protected]/Ahrak/gnome-shell-extension-disable-hot-corners.git' does not exist
1
  • A reminder for users of ubuntu 22.04 and who installed "Hide Top Bar" extension: Try toggle off its "show panel when mouse approach edge of screen" option.
    – unifreak
    Commented Sep 7, 2022 at 11:52

9 Answers 9

132

Recent GNOME Versions

Recent GNOME versions don't require gnome-tweak-tool to change this.

You can find a switch for Activities Hot Corner in GNOME Settings application under Multitasking category.

Multitasking Category in Gnome Settings application

A screencast (with gnome-tweak-tool):

Instructions for legacy GNOME releases (GNOME Tweaks required).

Hot corner configuration in gnome tweak tools screencast

15
  • 1
    I've added a link to a screencast with an english interface.
    – mmai
    Commented Apr 8, 2018 at 7:13
  • 9
    Which version of Tweaks is that? I don't have this option in 3.28.1.
    – orschiro
    Commented May 11, 2018 at 14:30
  • 6
    this works until i lock the screen and unlock it again to resume my session. any thoughts on how to make this setting "stick"?
    – amc
    Commented Jun 8, 2018 at 3:24
  • 3
    Yeah, this doesn't work when I suspend/resume. See @user230910's answer.
    – Julian
    Commented Apr 17, 2019 at 15:43
  • 6
    proper answer is: gsettings set org.gnome.desktop.interface enable-hot-corners false
    – razor
    Commented Nov 10, 2020 at 14:20
47

Command-line way

If you are looking for the gsettings command for this "Activities Overview Hot Corner" option in GNOME Tweaks:

enter image description here

then, the key is gsettings set org.gnome.shell enable-hot-corners true|false

example:

gsettings set org.gnome.shell enable-hot-corners true
gsettings set org.gnome.shell enable-hot-corners false

enter image description here


EDIT

Recent version of GNOME seems to be

gsettings set org.gnome.desktop.interface enable-hot-corners true
gsettings set org.gnome.desktop.interface enable-hot-corners false
7
  • 1
    exactly what i was looking for, thanks! One more question: How did you "merge" the bash and the top-bar into one, single bar at the bottom?
    – kerner1000
    Commented Nov 30, 2018 at 11:49
  • 1
    The setting was move to org.gnome.desktop.interface
    – aross
    Commented Nov 2, 2020 at 11:12
  • 1
    yw, and thx for a great answer.
    – aross
    Commented Nov 2, 2020 at 15:45
  • 1
    i'm using Debian 10, and the settings is in neither desktop.interface nor shell. Where can I find it?
    – xdavidliu
    Commented Dec 20, 2020 at 14:09
  • 1
    @xdavidliu If you failed to find the setting, it usually means that your gnome-shell is too old. You should either upgrade your gnome to 3.36+ (if your distribution allows), or use a gnome extension (refer to my answer).
    – recolic
    Commented May 6, 2021 at 5:55
17

Tried frans' solution:

git clone github.com:HROMANO/nohotcorner.git [email protected]:
Permission denied (publickey).

Why not install the gnome-shell-extension directly? It's much easier, and works for gnome in every linux distribution.

https://extensions.gnome.org/extension/118/no-topleft-hot-corner/


Update for gnome>3.36:

This extension is not needed anymore as it is now supported by the shell itself. You can switch off the hotcorner with a gsettings or using gnome-tweak tool.

12

If you have already enabled the infrastructure to use Gnome-Extensions, you can simply go to the extensions webpage, search for "hot corners" and click the switch to turn it on.

Here is an example of the url:

https://extensions.gnome.org/extension/118/no-topleft-hot-corner/

Here is a screenshot of the button to switch on:

Screenshot of extendsions.gnome.org link

Obviously this assumes that you have already installed all the bits to make extensions work from the website - see the section on installing shell extensions from a browser here:

https://linoxide.com/linux-how-to/install-gnome-shell-extensions-gui-cli/

8

Take k0pernikus' answer but name the directory correctly:

cd ~/.local/share/gnome-shell/extensions/
git clone github.com:HROMANO/nohotcorner.git [email protected]

works for me

7

Funny how an ancient post pops up and does not have a recent answer, non of the solutions work for recent versions of Gnome Shell.

For Fedora Worstation 36 with Gnome Shell 42.4, this can be found in settings under multitasking, see screenshot (Active Screen Edges can be switched there too):

enter image description here update : still valid on Fedora 39 and Gnome 45.5 ! Assuming it's the same for the in between version of Fedora 37 and 38.

I assume Gnome 43 will have this too.

1
  • 1
    For Ubuntu 22, this is the only solution that worked for me. Thanks.
    – gimmegimme
    Commented Nov 7, 2022 at 14:03
5

The option to disable the "hot corner" wasn't available on the latest version of gnome-tweak-tools up to this answer date, so I manage to add the option with an extension: disable hot corner extension

Extension options

Just download the compressed file and add it the "Extensions" option, after that enable or disable the "hot corner" as you wish.

2

I switched to No Topletft Hot Corner by HROMANO

cd ~/.local/share/gnome-shell/extensions/
git clone github.com:HROMANO/nohotcorner.git
3
  • 2
    You need to call this extension [email protected] - at least in the current version. The extension won't start otherwise and you get an error message Gjs-WARNING **: JS ERROR: Could not load extension nohotcorner: Error: uuid "[email protected]" from metadata.json does not match directory name "nohotcorner"
    – frans
    Commented Nov 17, 2016 at 9:26
  • yes, those who read this: use @frans answer above
    – MInner
    Commented Nov 19, 2016 at 23:55
  • 1
    I get permission denied trying to clone.
    – Julian
    Commented Apr 17, 2019 at 15:39
1

Install Gnome Tweak Tools with:

sudo apt-get install gnome-tweak-tool.

Once installed open the tweak tool app and go to the option marked extensions on the left:

Next go to the following location HERE and download the "No Top Left Corner" extension by Azuri. This is an extension to work with Gnome-Tweak Tool. When you download, you will be asked for the gnome shell version you are using. You can check it with the following command:

gnome-shell --version.

Once downloaded, go back to the Tweak Tool and at the end of the extensions list is a File button to add more extensions. Click it, and then select the zip file containing the shell extension downloaded.

That's it. It may require a restart. For me it asked for a restart, but even before that the hot corner was off.

1
  • The No Top Left Corner is not required. The GNOME Tweaks has a Activities Overview Hot Corner toggle in Top Bar option in the sidebar. Commented Sep 30, 2021 at 4:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .